Bug 475389 - Loss of hinting instructions on changes/saving.
Loss of hinting instructions on changes/saving.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 20:42 EST by Caius Chance
Modified: 2008-12-15 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 17:15:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2008-12-08 20:42:44 EST
Description of problem:
When I change the glyph point on a certain glyph, fontforge pops up a window of message like "all the glyphs which refer to this glyph will be changed".

After that, there are some characters on the main window (the one with grid of glphs) have highlighted in blue color. Such highlights means empty instructions on such glyphs.

Version-Release number of selected component (if applicable):
fontforge-20080828-1.fc10.i386

How reproducible:
Often.

Steps to Reproduce:
- prepare f10
- login to desktop env
- ensure latest fontforge is installed
- start fontforge w/ http://fedorapeople.org/~cchance/packages/liberation-fonts/LiberationMono-BoldItalic.sfd loaded
- pick a glyph and change some glyph points on it
- check results

Actual results:
Changes only are applied to the glyph edited.

Expected results:
Some blue highlights on main window (with grid of all glpyhs), which means empty hinting instructions on such glyphs.

Additional info:
Copied this bug to upstream mailing list.
Comment 1 Kevin Fenzi 2008-12-14 20:49:21 EST
It's sounding like upstream is saying this is not a bug, as changing one glyph may change others hinting instructions. 

Do you want to keep this open and consult more with upstream? 
Or shall we close it?
Comment 2 Caius Chance 2008-12-14 22:50:58 EST
ok please close this bug

Note You need to log in before you can comment on or make changes to this bug.