Bug 475409 - javaws
javaws
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 23:04 EST by NM
Modified: 2008-12-11 12:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 10:17:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NM 2008-12-08 23:04:22 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

I had no problems with javaws until after December 7, 2008 update (not sure its related...). Old jlnp files stopped working. And javaws -about produces the following error:
user@localh ~/tmp]$ javaws -about
netx v0.5 - (C)2001-2003 Jon A. Maxwell (jmaxwell@users.sourceforge.net)

Launching about window...
java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:101)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJar(JarSigner.java:227)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:202)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:637)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:325)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:101)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJar(JarSigner.java:227)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:202)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:637)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:325)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:519)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:331)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	... 2 more
Caused by: 
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:331)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)


Please help,
regards,
NM


Reproducible: Always

Steps to Reproduce:
1.from command prompt run 
2.javaws -about
3.


Expected Results:  
Should see 'about' window with test screens and demos.
Comment 1 Lillian Angel 2008-12-09 10:17:43 EST
It works with the java-1.6.0-openjdk update in rawhide. Can you please try again?
Comment 2 NM 2008-12-09 11:25:43 EST
I updated 6 files from rawhide starting with java-1.6.0-openjdk...
java -version produces:

java version "1.6.0_0"
IcedTea6 1.4 (fedora-8.b14.fc11-x86_64) Runtime Environment (build 1.6.0_0-b14)
OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode)

When run as root i do get correct window fro javaws -about. However when run as ordinary user I am getting the same error:

user@localh ~/tmp]$ javaws -about
netx v0.5 - (C)2001-2003 Jon A. Maxwell (jmaxwell@users.sourceforge.net)

Launching about window...
java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:101)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJar(JarSigner.java:227)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:202)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:641)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:325)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:101)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJar(JarSigner.java:227)
	at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:202)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:641)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:325)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:519)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:331)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	... 2 more
Caused by: 
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:331)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:157)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:214)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:509)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:334)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)

Thanks anyway
Comment 3 NM 2008-12-09 11:32:55 EST
It this a permission issue? If yes where should I check?
Thanks
Comment 4 Lillian Angel 2008-12-09 11:53:46 EST
i tested this as a user and as root, works in both cases.
Comment 5 NM 2008-12-09 12:52:30 EST
Apparently something wrong on my side. I do not know what...Thanks.
Comment 6 Lubomir Rintel 2008-12-11 09:27:26 EST
NM: You may want to check whether your javaws link points to actual javaws binary of java-1.6.0-openjdk package (1), whether your package is not corrupted (2) and possibly find out which file is it opening (3):

(1) $ ls -l $(which javaws)
(2) $ rpm -Vf /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/javaws
(3) $ strace -efile /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/javaws
Comment 7 NM 2008-12-11 12:18:58 EST
I run it as root.

1) ls -l /usr/bin/javaws 
returns
lrwxrwxrwx 1 root root 24 2008-11-28 20:17 /usr/bin/javaws -> /etc/alternatives/javaws
ls -l /etc/alternatives/javaws 
returns
lrwxrwxrwx 1 root root 48 2008-12-09 11:12 /etc/alternatives/javaws -> /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws
finally 
ls -l /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws
returns
-rwxr-xr-x 1 root root 40528 2008-12-05 16:49 /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws

2) rpm -Vf /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws
returns nothing at all (i guess this is good?)

3) Finally 
strace -efile /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws
produces a long output with a lot of errors (?). Please chek it out below:
execve("/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws", ["/usr/lib/jvm/jre-1.6.0-openjdk.x"...], [/* 28 vars */]) = 0
readlink("/proc/self/exe", "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/javaws"..., 4096) = 61
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/x86_64", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/x86_64", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/x86_64", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/x86_64", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli", 0x7ffff2b147c0) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib64/libz.so.1", O_RDONLY)      = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libpthread.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libjli.so", O_RDONLY) = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libc.so.6", O_RDONLY)      = 3
readlink("/proc/self/exe", "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/javaws"..., 4096) = 61
access("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libjava.so", F_OK) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/jvm.cfg", O_RDONLY) = 3
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libjvm.so", {st_mode=S_IFREG|0755, st_size=8651392, ...}) = 0
execve("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/javaws", ["/usr/lib/jvm/jre-1.6.0-openjdk.x"...], [/* 29 vars */]) = 0
readlink("/proc/self/exe", "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/javaws"..., 4096) = 61
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/tls", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/tls", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../jre/lib/amd64/jli", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/tls/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/tls", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/tls/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/tls", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/tls/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/tls/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/tls/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/tls", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/x86_64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/x86_64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64/libz.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64", 0x7fff015d61a0) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib64/libz.so.1", O_RDONLY)      = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libpthread.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libpthread.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libpthread.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libjli.so", O_RDONLY) = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libdl.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libc.so.6", O_RDONLY)      = 3
readlink("/proc/self/exe", "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/javaws"..., 4096) = 61
access("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libjava.so", F_OK) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/jvm.cfg", O_RDONLY) = 3
stat("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libjvm.so", {st_mode=S_IFREG|0755, st_size=8651392, ...}) = 0
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libjvm.so", O_RDONLY) = 3
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/../lib/amd64/jli/libm.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server/libm.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/libm.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib64/libm.so.6", O_RDONLY)      = 3

Usage:   javaws [-run-options] <jnlp file>
         javaws [-control-options]

control-options:
  -about                Shows a sample application.
  -viewer               Shows the trusted certificate viewer.

run-options:
  -basedir dir          Directory where the cache is kept.
  -arg arg              Adds an application argument before launching.
  -param name=value     Adds an applet parameter before launching.
  -property name=value  Sets a system property before launching.
  -update seconds       Update check if seconds since last checked.
  -license              Display the GPL license and exit.
  -verbose              Enable verbose output.
  -nosecurity           Disables the secure runtime environment.
  -noupdate             Disables checking for updates.
  -headless             Disables download window, other UIs.
  -strict               Enables strict checking of JNLP file format.
  -umask=value          Sets the umask for files created by an application.
  -help                 Print this message and exit.


Any help to understand all this would be rally appreciated.

Thanks a lot

Note You need to log in before you can comment on or make changes to this bug.