Bug 475449 - Duplicate asterisk.conf in config filename with path.
Duplicate asterisk.conf in config filename with path.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
: 483536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 04:45 EST by Jan ONDREJ
Modified: 2009-02-02 08:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-02 18:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-12-09 04:45:35 EST
Description of problem:
When starting/restarting asterisk, an error occurs.

Version-Release number of selected component (if applicable):
asterisk-1.6.0.1-2.fc10.i386


How reproducible: always

Steps to Reproduce:
1. service asterisk restart
  
Actual results:
[root@voip asterisk]# /etc/init.d/asterisk restart
Zastavenie asterisk:                                       [  OK   ]
Spustenie asterisk: Unable to open specified master config file '/etc/asterisk/asterisk.conf/asterisk.conf', using built-in defaults
                                                           [  OK   ]

Expected results:
Just OK 2 times, no error message.


Additional info:
Just remove seconf asterisk.conf in init script:
        if [ $AST_CONFIG ]; then
                ASTARGS="$ASTARGS -C $AST_CONFIG/asterisk.conf"
        fi

When trying to remove asterisk.conf string from sysconfig file, asterisk does not start, that there is no file of that name.
Comment 1 eric@christensenplace.us 2008-12-11 20:46:05 EST
Seeing the same thing.  Changed line 88 to just ...$AST_CONFIG
Comment 2 Jan ONDREJ 2008-12-14 11:31:45 EST
Seeing an update in bodhi:

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-9022

Works for me. Can somebody else confirm?

Btw, why this bug is not assigned yet and why there is no "close bugs" in this bodhi request?
Comment 3 Dan Trainor 2009-01-14 02:58:19 EST
Confirmed.
Comment 4 Jeffrey C. Ollie 2009-02-02 08:10:14 EST
*** Bug 483536 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.