Bug 475492 - ProjectM-pulseaudio - Crashes on startup
ProjectM-pulseaudio - Crashes on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: projectM-pulseaudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jameson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 09:34 EST by D.S. Ljungmark
Modified: 2009-05-09 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 23:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D.S. Ljungmark 2008-12-09 09:34:28 EST
Description of problem:
It crashes at startup

Version-Release number of selected component (if applicable):

projectM-pulseaudio-1.2.0-3.fc10.i386

How reproducible:

[spider@weaver]~% projectM-pulseaudio 
dir:/usr/share/projectM/config.inp 
reading ~/.projectM/config.inp 
configFile: /home/spider/.projectM/config.inp
MAX SAMPLES:2048
load config END 
unconnected: connecting... 
connectHelper:  "alsa_output.pci_8086_24c5_sound_card_0_alsa_playback_0.monitor" 
zsh: segmentation fault  projectM-pulseaudio

Steps to Reproduce:
1. install
2. start
3. crash
  
Actual results:
hard crash

Expected results:
No clue, never worked.

Additional info:
Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x0016d0a2 in RenderTarget::lock () from /usr/lib/libprojectM.so.2
#2  0x0019c3ab in Renderer::RenderFrame () from /usr/lib/libprojectM.so.2
#3  0x001697cb in projectM::renderFrame () from /usr/lib/libprojectM.so.2
#4  0x00144723 in QProjectMWidget::paintGL () from /usr/lib/libprojectM-qt.so.1
#5  0x002173eb in QGLWidget::glDraw () from /usr/lib/libQtOpenGL.so.4
#6  0x00215fbe in QGLWidget::paintEvent () from /usr/lib/libQtOpenGL.so.4
#7  0x0085647b in QWidget::event () from /usr/lib/libQtGui.so.4
#8  0x0021b27f in QGLWidget::event () from /usr/lib/libQtOpenGL.so.4
#9  0x007fe62c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#10 0x0080653a in QApplication::notify () from /usr/lib/libQtGui.so.4
#11 0x003bb1c1 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#12 0x0085f14e in ?? () from /usr/lib/libQtGui.so.4
#13 0x00854e40 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#14 0x009c20a4 in QWidget::repaint () from /usr/lib/libQtGui.so.4
#15 0x009c3b1f in ?? () from /usr/lib/libQtGui.so.4
#16 0x008562a6 in QWidget::event () from /usr/lib/libQtGui.so.4
#17 0x0021b27f in QGLWidget::event () from /usr/lib/libQtOpenGL.so.4
#18 0x007fe62c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#19 0x0080653a in QApplication::notify () from /usr/lib/libQtGui.so.4
---Type <return> to continue, or q <return> to quit--- 
#20 0x003bb1c1 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#21 0x003bbe45 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#22 0x003bc03d in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#23 0x003e5baf in ?? () from /usr/lib/libQtCore.so.4
#24 0x0599f238 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x059a28e3 in ?? () from /lib/libglib-2.0.so.0
#26 0x059a2aa1 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x003e57f8 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#28 0x00897485 in ?? () from /usr/lib/libQtGui.so.4
#29 0x003b988a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#30 0x003b9a4a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#31 0x003bc105 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#32 0x007fe4a7 in QApplication::exec () from /usr/lib/libQtGui.so.4
#33 0x08050e08 in main ()
Comment 1 Jameson 2008-12-27 16:23:48 EST
It appears to have been a bug in an underlying library as it wasn't working for me when this bug was posted, either, but I just got my main computer back up and running, and it is working with current updates.  Please, give it another shot.
Comment 2 Jameson 2008-12-30 23:48:11 EST
As far as I can tell, the problem was somewhere else, possibl Qt?  Either way updates of other software have fixed the issue.
Comment 3 D.S. Ljungmark 2009-01-16 06:28:41 EST
Gave a full go with all current updates in F10, And it is still crashing just after the window first shows/paints.
Comment 4 Kieran Clancy 2009-05-09 19:20:08 EDT
I have this problem as well, with all the latest updates. Please consider re-opening the bug report.

Note You need to log in before you can comment on or make changes to this bug.