Bug 475502 - [LTC 5.4 FEAT] ACPI C3/C4 Support [201240]
[LTC 5.4 FEAT] ACPI C3/C4 Support [201240]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All All
high Severity high
: alpha
: 5.4
Assigned To: Peter Martuccelli
Red Hat Kernel QE team
: FutureFeature, OtherQA
Depends On:
Blocks: 445204 483701 483784 488642 488646
  Show dependency treegraph
 
Reported: 2008-12-09 10:30 EST by IBM Bug Proxy
Modified: 2011-02-22 04:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 08:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50525 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 10:30:57 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201240]
a. Name of Feature:	ACPI C3/C4 Support
b. Feature Description
Power savings is quickly becoming one of the main focus areas for system x.  We need to ensure
additional ACPI power states (c-states), particularly c3/c4 deep sleep modes, are supported in Linux
so they are ready to be used at the enterprise level, and in support of IBM's power management strategy.

Additional Comments:	Once we get C3/C4 enabled hardware we will be validating this feature in 5.4. 
One bug fix that we are looking for is bugzilla 474091 (TSC keeps running in C3+).

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Core Kernel: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	Some of this may just work, because laptops already support this. For
Servers, it must be tested. However, until we have servers that support C3/C4, it's difficult to
guess which upstream kernel any code (if needed) will be targeted for.

3. Business Case
IBM Active Energy Manager will require ACPI C3/C4 Support

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com
Comment 1 John Jarvis 2008-12-23 16:18:43 EST
IBM is signed up to test and provide feedback.
Comment 2 John Jarvis 2009-01-15 09:16:54 EST
What is the status of the C3/C4 enabled hardware?  Has this been tested with the latest 5.3 code?
Comment 3 IBM Bug Proxy 2009-01-15 11:10:58 EST
We have verified C3/C4 support on an iDataPlex dx340. We now have C3/C4 enabled on x3550 M2 and x3650 M2. We will confirm RHEL5.3 works correctly on those platforms and report the results here. If all goes well this can be closed.
Comment 4 RHEL Product and Program Management 2009-02-16 10:19:09 EST
Updating PM score.
Comment 5 John Jarvis 2009-03-24 15:19:45 EDT
Any update on the testing mentioned in this bug?  Did this work correctly with RHEL 5.3?
Comment 6 IBM Bug Proxy 2009-03-25 20:00:26 EDT
------- Comment From djwong@us.ibm.com 2009-03-25 19:51 EDT-------
Seems to work fine with the RHEL 5.3 RC2 kernel (2.6.18-128.el5), thanks. :)
Comment 7 John Jarvis 2009-03-26 08:46:01 EDT
Closing CURRENTRELEASE based on comment 6
Comment 8 IBM Bug Proxy 2011-02-22 04:41:58 EST
------- Comment From  2011-02-22 04:38 EDT-------
We are reviewing this as a part of backlog bug clean up activity.
Please feel free to reopen once you have any valid update.

Thanks
Muni

------- Comment From  2011-02-22 04:40 EDT-------
(In reply to comment #12)
> We are reviewing this as a part of backlog bug clean up activity.
> Please feel free to reopen once you have any valid update.
>
> Thanks
> Muni

Closed this bug as per Redhat's comment.

Note You need to log in before you can comment on or make changes to this bug.