Bug 475520 - [LTC 5.5 FEAT] Intuitive dump device configuration workflow and dialogue [201624]
[LTC 5.5 FEAT] Intuitive dump device configuration workflow and dialogue [201...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
s390x All
high Severity high
: beta
: 5.5
Assigned To: Anaconda Maintenance Team
Release Test Team
: FutureFeature, OtherQA, Reopened
: 511973 566205 (view as bug list)
Depends On:
Blocks: 533941 481160 531114
  Show dependency treegraph
 
Reported: 2008-12-09 11:01 EST by IBM Bug Proxy
Modified: 2010-03-09 12:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-14 11:39:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Distribution Installer Support for Linux on System z dump tools (71.13 KB, application/pdf)
2009-01-13 11:01 EST, IBM Bug Proxy
no flags Details
Example perl script showing mechanism to configure dump on DASD (5.93 KB, text/plain)
2009-01-13 11:01 EST, IBM Bug Proxy
no flags Details
Example perl script showing mechanism to configure dump on SCSI (4.96 KB, text/plain)
2009-01-13 11:01 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50528 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 11:01:35 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201624]
a. Name of Feature:	Intuitive dump device configuration workflow and dialogue
b. Feature Description
Distribution configuration tools need to provide a dialog to prepare I/O devices for dump, during
the installation and post-installation.

 The dialog needs to meet the following requirements:
 - intuitive, i.e. follow the expectation of the user
 - guided, i.e. online help texts should be available for each input field
 - undoable, i.e. customer should be able to correct mistakes

Additional Comments:	IBM System z Development has done a study about what would be needed, and as a
result, there is some documentation and scripts which we would give to Red Hat. We request that Red
Hat implements it in the installer and post-installer GUI or TUI.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Affects Desktop: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	zSeries
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
The customer will have a dump disk ready to use if any problem occurs without having troubles to
configure it, which will result on a better serviceability, and in result improve the customer
satisfaction.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):

Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 John Jarvis 2008-12-22 12:08:51 EST
Where is the documentation and scripts mentioned in this request or how is it going to be provided?  Please attach them to this request.  The precise work items will still need to be listed in this bug along with a test plan.
Comment 2 IBM Bug Proxy 2009-01-13 11:01:37 EST
Created attachment 328880 [details]
Distribution Installer Support for Linux on System z dump tools
Comment 3 IBM Bug Proxy 2009-01-13 11:01:44 EST
Created attachment 328881 [details]
Example perl script showing mechanism to configure dump on DASD
Comment 4 IBM Bug Proxy 2009-01-13 11:01:49 EST
Created attachment 328882 [details]
Example perl script showing mechanism to configure dump on SCSI
Comment 5 IBM Bug Proxy 2009-01-13 11:10:47 EST
Hello Red Hat,

please find detailed documentation and scripts in the following three attachments:
attachment 42258 : Distribution Installer Support for Linux on System z dump tools
attachment 42259 : Example perl script showing mechanism to configure dump on DASD
attachment 42260 : Example perl script showing mechanism to configure dump on SCSI

Maybe the section
<quote>
Clear the disk of fs labels, lvm formatting, mdadm formatting, etc. This is important to prevent the disk from being automatically used for something other than as dump device.
Examples:
tune2fs -L '' /dev/dasdd1
pvremove /dev/dasdd1
mdadm --zero-superblock
</quote>
after setting the dump device online and before preparing the device for dumps in http://kbase.redhat.com/faq/docs/DOC-9768 might also be helpful to prevent known issues. Otherwise attachment 42258 should take precedence.

Further details can be found in:
"Using the Dump Tools - SC33-8290-02"
and if necessary also in the sections on fdasd and zipl of
"Device Drivers, Features, and Commands - SC33-8289-04"
on http://www.ibm.com/developerworks/linux/linux390/october2005_documentation.html
Comment 6 IBM Bug Proxy 2009-04-27 13:12:26 EDT
------- Comment From mgrf@de.ibm.com 2009-04-27 13:01 EDT-------
Hello Red Hat, Hi John,
What is the status regarding RHEL 5.4 acceptance for this feature?
Comment 7 John Jarvis 2009-04-27 14:33:08 EDT
This feature is denied for RHEL 5.4 due to a lack of resources.
Comment 8 IBM Bug Proxy 2009-04-28 08:31:21 EDT
------- Comment From gmuelas@de.ibm.com 2009-04-28 08:27 EDT-------
Hello Red Hat,

- if IBM takes over the QA (Test) responsibility for this feature, would you still have not resources to implement it?

- IBM believes that this it is a very interesting feature for the RHEL 5 System z customers, but since to implement this feature, RHEL would need implementation of a tool using the scripts provided and we already in the 4th minor update, is Red Hat interested in this feature at all for future minor updates in RHEL 5, assuming you have the resources for future RHEL 5 minor updates?

Thank you!
Gonzalo Muelas Serrano.
Comment 9 John Jarvis 2009-06-11 09:25:10 EDT
Closing as WONTFIX for RHEL 5.4 due to lack of capacity, please feel free to
reopen to request this feature for consideration for RHEL 5.5
Comment 10 IBM Bug Proxy 2009-07-15 08:12:38 EDT
------- Comment From mgrf@de.ibm.com 2009-07-15 08:06 EDT-------
Defering feature request to RHEL 5.5
Comment 11 John Jarvis 2009-07-15 09:27:01 EDT
Reopening and putting on the RHEL 5.5 tracker for consideration for inclusion in that release.
Comment 12 IBM Bug Proxy 2009-07-16 08:10:57 EDT
------- Comment From mgrf@de.ibm.com 2009-07-16 08:05 EDT-------
This request got a new feature BZ for RHEL 5.5 that is

LTC 54797 - RHBZ 511973  [LTC 5.5 FEAT] Intuitive dump device configuration workflow and dialogue [201624]

Therefore closing this for RHEL 5.4 with "willnotfix" based on Red Hat reject
Comment 13 IBM Bug Proxy 2009-08-03 08:11:42 EDT
------- Comment From mgrf@de.ibm.com 2009-08-03 08:06 EDT-------
*** Bug 54797 has been marked as a duplicate of this bug. ***

------- Comment From mgrf@de.ibm.com 2009-08-03 08:08 EDT-------
As agreed with John:

Re-open old RHEL 5.4 feature to request for inclusion into RHEL 5.5.
That is to have done discussions included in feature request

Note:
The new opened RHEL 5.5 feature BZ get closed
LTC 54797 - RHBZ 511973 [LTC 5.5 FEAT] Intuitive dump device configuration workflow and dialogue [201624]
Comment 14 Chris Lumens 2009-08-07 11:55:29 EDT
*** Bug 511973 has been marked as a duplicate of this bug. ***
Comment 15 Dave Anderson 2009-08-14 15:51:27 EDT
This BZ should *not* have been assigned the "crash" component -- the crash
component is only for the user-space crash utility, which is used to analyze
kernel crash dumpfiles.

This feature should be assigned to "anaconda", or some other kernel
installation related component.

JJarvis -- can you reassign this BZ to an appropriate owner?
Comment 16 IBM Bug Proxy 2009-09-04 04:01:09 EDT
------- Comment From mgrf@de.ibm.com 2009-09-04 03:57 EDT-------
There is no IBM code to be submitted for this feature
Comment 17 John Jarvis 2009-10-26 09:26:05 EDT
IBM is signed up to test and provide feedback.
Comment 19 Denise Dumas 2009-11-03 09:41:44 EST
Per our discussion last week, I will set up a technical meeting on this BZ and
other IBM requests in early January to look at this for a future RHEL5 release.
Denise
Comment 20 David Cantrell 2010-01-12 11:16:17 EST
This feature request needs to be implemented in Fedora rawhide (anaconda upstream) before we should consider it for RHEL.  Given the current RHEL 5 schedule, I do not see us backporting this feature to a future RHEL 5 release.  However, I can see us backporting to RHEL 6.1.  Regardless, we need to work up the feature upstream first, then we can consider pulling it in to RHEL.
Comment 21 IBM Bug Proxy 2010-01-13 04:30:57 EST
------- Comment From gmuelas@de.ibm.com 2010-01-13 04:29 EDT-------
Hello Red Hat,
I understood from Denise that we (Red Hat and IBM) wanted to have a tech. call to discuss this feature in Jan 2010 (see RH Comment #19), and that it was ok for Red Hat that we requested for RHEL 5.x (see RH Comment #9) and RHEL 6.x although was not yet upstream (since upstream can still not be tested).

Is my understanding not correct and you do not want to have a tech. call anymore or interested for RHEL 5.x?

Thank you for your support,
Gonzalo Muelas Serrano.
Comment 22 John Jarvis 2010-01-14 11:39:30 EST
Setting to CLOSED WONTFIX due to dev nak.
Comment 23 John Jarvis 2010-03-09 12:26:36 EST
*** Bug 566205 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.