Bug 475543 - Conflict in translation install, breaks install
Conflict in translation install, breaks install
Product: Fedora
Classification: Fedora
Component: libkdcraw (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-09 11:31 EST by Warren Togami
Modified: 2008-12-21 17:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-21 16:45:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-12-09 11:31:56 EST
file /usr/share/locale/ja/LC_MESSAGES/libkdcraw.mo from install of kde-l10n-Japanese-4.1.3-1.fc10.noarch conflicts with file from package libkdcraw-0.1.4-2.fc9.x86_64
Comment 1 Marcin Garski 2008-12-09 17:12:37 EST
There is no libkdcraw package in F10 repo, in what situation does this error occur?
Comment 2 Rex Dieter 2008-12-09 19:25:20 EST
Upgrade (from F-8, F-9).  

Looks like we goofed and didn't Obsoletes this anywhere.
Comment 3 Marcin Garski 2008-12-21 14:49:39 EST
Rex you have Obsoletes this in kdegraphics-libs:

%if 0%{?obsolete_kde3_kipi}
Obsoletes: libkdcraw < 0.2.0, libkexiv2 < 0.4.0, libkipi < 0.2.0

Problem still exist because there is no Provides for libkdcraw and other packages in -libs (only -devel have Obsoletes and Provides for this).
Comment 4 Rex Dieter 2008-12-21 15:43:56 EST
True Obsoletes have been added, but I fail to see how a lack of Provides is a problem here.
Comment 5 Marcin Garski 2008-12-21 16:37:10 EST
Let's assume that libkdcraw is the only installed package on F9 (without digikam, kdegraphics*). Updating to F10 will cause problems, because only kdegraphics-libs Obsoletes libkdcraw, as it isn't installed it will not remove libkdcraw, then if you try to install kde-l10n-Japanese you will get errors like in this bug.

If kdegraphics-libs will Provides libkdcraw, during update it will be installed replacing libkdcraw and this bug won't appear.
Comment 6 Rex Dieter 2008-12-21 16:38:54 EST
I think you misunderstand how Obsoletes works (or I do) :)

As I understand it, Obsoletes will remove the Obsoleted pkg on upgrade.  Provides doesn't play into it.
Comment 7 Rex Dieter 2008-12-21 16:45:55 EST
That said, now that the Obsoletes have been added, 
* Tue Nov 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-3
- respin libkdcraw/libkexiv2 patches
- Obsoletes: libkdcraw libkexiv2 libkipi (F10+)

I don't see anything else to do here -> closing.
Comment 8 Rex Dieter 2008-12-21 16:47:28 EST
Brainstorming out loud:  we could consider making separate libkipi, libkexiv2, libkdcraw (sub)pkgs from kdegraphics, which would also help in such cases.
Comment 9 Marcin Garski 2008-12-21 17:41:25 EST
"As I understand it, Obsoletes will remove the Obsoleted pkg on upgrade." <- You are absolutely right. In this case _if_ user _install_ kdegraphics-libs it will remove libkdcraw package, and everything is fine.

Try to imagine what will happen if user _won't_ install kdegraphics-libs, libkdcraw won't be removed. We should care about this too, and such scenario was presented in Comment #5
Comment 10 Rex Dieter 2008-12-21 17:45:00 EST
iirc, Obsoletes are considered in 'yum update' too (and during upgrades).

Note You need to log in before you can comment on or make changes to this bug.