Bug 475548 - [LTC 5.4 FEAT] FCP - Performance data collection (blktrace) [201729]
[LTC 5.4 FEAT] FCP - Performance data collection (blktrace) [201729]
Status: CLOSED DUPLICATE of bug 472898
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.4
s390x All
high Severity high
: alpha
: 5.4
Assigned To: Eric Sandeen
BaseOS QE
: FutureFeature, OtherQA
Depends On:
Blocks: 445204 483784
  Show dependency treegraph
 
Reported: 2008-12-09 11:41 EST by IBM Bug Proxy
Modified: 2009-06-20 04:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 17:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50351 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 11:41:33 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201729]
a. Name of Feature:	FCP - Performance data collection (blktrace)
b. Feature Description
The item comprises:
 
 a) facilities which provide performance relevant data (see below) at any time
 
 b) facilities which collect the data provided by a), then associate it with a time stamp and and
store it for future processing
 
      - these facilities are configurable in regard of the type and amount of data collected for the
purpose of reducing the amount of temporarily stored data.
 
      - when data is taken as samples, the sampling interval is configurable
 
      - collected data can be filtered by e.g masks for valid stack components (see below) before
data is stored for further processing
 
 
 Data collected comprises:
 
 a) Performance relevant data about stack components as Linux devices, SCSI LUNs and HBA and storage
controller information
 
 b) Per stack component: current values of relevant measurements as throughput, utilization and
other applicable measurements 
 
 c) Statistical aggregations (min, max average, histogram) of data associated with I/O requests as
size, latency per component and in total.
 
 
 Pick up latest version from blktrace package and if IBM contribution, not yet included, apply it.

RHEL 6.0 request: https://bugzilla.redhat.com/show_bug.cgi?id=464179

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Backport
Category:	RAS
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	> blktrace 0.99.3

3. Business Case
This item will make possible to have a better understanding of the SCSI activities and performance
of the customer system, being able afterward to better solve FCP issues regarding customer's SCSI
workloads.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 John Jarvis 2008-12-22 12:22:16 EST
What would be the exact steps to satisfy this request?  Is it just a matter of including blktrace or are there other kernel or userspace requirements?
Comment 2 IBM Bug Proxy 2009-01-19 08:00:02 EST
The code for this feature is upstream accepted is with blktrace 1.0.0
Comment 3 IBM Bug Proxy 2009-01-23 09:02:34 EST
This feature has the coresponding feature requests:

201591	FCP - Performance Data collection & analysis (userspace)	LTC 50340  RHBZ 475333
201590	FCP - Performance Data collection  (kernel)	Submitted	LTC 50339  RHBZ 475334

The blktrace version to be included is the upstream version plus
the following two commits with bug fixes that  are required for this feature, and will be upstream integrated within the next  blktrace  version

(git commit 61165962f86cb2de0b163f6083bff5649f692e91 and b3ee499dd143aeaed311bf3bc6d14871168b6657).

Attention, the maintainer has noch changed the version number of blktrace.
Comment 4 Eric Sandeen 2009-02-06 11:57:10 EST
The existing kernel config should already support the blktrace tool, FWIW.

-Eric
Comment 5 Denise Dumas 2009-02-13 11:38:20 EST
Assigning to Eric
Comment 6 Eric Sandeen 2009-02-17 12:55:27 EST
For commit b3ee499dd143aeaed311bf3bc6d14871168b6657 as noted in comment #3 - "__BLK_TA_ABORT" and blk_abort_queue() are not currently present in the rhel5 kernel, so I don't think this fix is needed in the RHEL5 blktrace, is this correct?

Thanks,
-Eric
Comment 7 IBM Bug Proxy 2009-02-18 04:00:41 EST
It is absolutely necessary that the kernel API and blktrace user space match.
And we need to make sure that the blktrace API doesn't change (apart from additions).

So, if you leave out ABORT, we still need to make sure that the id for the ABORT is reserved and that it is not used by DRV_DATA. We don't want to reshuffle those ids later on, when ABORT gets added eventually.

+       __BLK_TA_ABORT,                 /* request aborted */
__BLK_TA_DRV_DATA,              /* binary driver data */

It would be feasible to explicitely list the assigned id for DRV_DATA in that enum.

My preferred solution would be to put in ABORT, at least in the header file, because this would be closest to the upstream version.
Comment 8 Eric Sandeen 2009-02-25 12:18:45 EST
Sure, that makes sense, thanks.

-Eric
Comment 11 Suzanne Yeghiayan 2009-03-20 17:24:50 EDT

*** This bug has been marked as a duplicate of bug 472898 ***
Comment 12 Eric Sandeen 2009-04-17 16:49:29 EDT
Note, these 2 patches are now committed & built in blktrace-1.0.0-3.el5.

Note You need to log in before you can comment on or make changes to this bug.