Bug 475608 - Missing updated gnome-packagekit rpm
Missing updated gnome-packagekit rpm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 14:00 EST by H.J. Lu
Modified: 2009-01-14 08:46 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:46:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of yum trying to install packages from wrong arch (30.19 KB, text/plain)
2008-12-11 10:17 EST, Matt Castelein
no flags Details

  None (edit)
Description H.J. Lu 2008-12-09 14:00:37 EST
When I tried to update my Fedora/10 on x86-64 on Dec. 9, 2008,
I got

--> Finished Dependency Resolution
gnome-packagekit-0.3.9-8.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libpackagekit-glib.so.10()(64bit) is needed by package gnome-packagekit-0.3.9-8.fc10.x86_64 (installed)
Error: Missing Dependency: libpackagekit-glib.so.10()(64bit) is needed by package gnome-packagekit-0.3.9-8.fc10.x86_64 (installed)
Comment 1 Ben Liblit 2008-12-09 16:14:22 EST
i386 is affected as well.

   latest posted gnome-packagekit:
      version-release: 0.3.9-8.fc10
      requires: libpackagekit-glib.so.10

   latest posted PackageKit-glib
      version-release: PackageKit-glib-0.3.11-4.fc10
      provides: libpackagekit-glib.so.11

Presumably we need a new gnome-packagekit built against libpackagekit-glib.so.11.
Comment 3 Samster 2008-12-10 09:37:39 EST
Also --  kpackagekit-0.3.1-4.fc10.x86_64

Update Deps Errors--

libpackagekit-qt.so.10()(64bit) is needed by package kpackagekit-0.3.1-4.fc10.x86_64 : Success - empty transaction

libpackagekit-glib.so.10()(64bit) is needed by package gnome-packagekit-0.3.9-8.fc10.x86_64
Comment 4 Chris Jones 2008-12-11 04:47:13 EST
Dito for i386:

kpackagekit-0.3.1-4.fc10.i386 from fedora has depsolving problems
  --> Missing Dependency: libpackagekit-qt.so.10 is needed by package kpackagekit-0.3.1-4.fc10.i386 (fedora)
Error: Missing Dependency: libpackagekit-qt.so.10 is needed by package kpackagekit-0.3.1-4.fc10.i386 (fedora)

This blocks the installation of KDE using - yum groupinstall "KDE (K Desktop Environment)"
Comment 5 Matt Castelein 2008-12-11 10:17:38 EST
Created attachment 326628 [details]
Output of yum trying to install packages from wrong arch

Something happened with this in the last 24 hours.. Now my system wants to install a TON of i386 packages onto my x86_64 system, and those also fail on deps.
Comment 6 Michal Jaegermann 2008-12-11 11:21:22 EST
Re: comment #2

A bunch of packages were announced on 2008-Dec-10 as available in updates for Fedora 10. That includes PackageKit-0.3.12-1.fc10, kpackagekit-0.3.1-9.fc10, gnome-packagekit-0.3.12-1.fc10 and others (like glibc-2.9-3, and gimp-2.6.3-2.fc10 and iproute-2.6.27-1.fc10 and more).  NONE of corresponding binary rpms so far showed up on mirrors but packages from the next day annoucements are already there.  It looks like that the whole batch was lost.  Who should be really alarmed here?
Comment 7 Paul "KK4DUY" Bransford 2008-12-11 13:23:39 EST
I was having similar problems all the way back on 12/7, on both an x86_64 and i386 machine.

The difference was that repeat applications of "yum --skip-broken update" eventually updated everything. Now, with these recent changes, it's back again but I can't get them to play nice.
Comment 8 Matt Castelein 2008-12-13 17:22:01 EST
Today's update fixed this for me..

Updated:
  PackageKit.x86_64 0:0.3.12-1.fc10                                             
  PackageKit-glib.x86_64 0:0.3.12-1.fc10                                        
  PackageKit-udev-helper.x86_64 0:0.3.12-1.fc10                                 
  PackageKit-yum.x86_64 0:0.3.12-1.fc10                                         
  PackageKit-yum-plugin.x86_64 0:0.3.12-1.fc10                                  
  busybox.x86_64 1:1.10.3-4.fc10                                                
  gawk.x86_64 0:3.1.6-2.fc10                                                    
  gnome-packagekit.x86_64 0:0.3.12-1.fc10                                       
  irqbalance.x86_64 2:0.55-12.fc10                                              
  libarchive.x86_64 0:2.5.5-2.fc10                                              
  system-config-samba.noarch 0:1.2.67-3.fc10                                    
  system-config-services.noarch 0:0.99.28-3.fc10
Comment 9 Alexander Todorov 2008-12-15 04:33:33 EST
works for me as well
Comment 10 Richard Hughes 2009-01-14 08:46:27 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.