Bug 475643 - cpuscaling fails on Nehalem processors with TurboBoost(IDA) enabled.
cpuscaling fails on Nehalem processors with TurboBoost(IDA) enabled.
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 16:31 EST by Rob Landry
Modified: 2014-03-25 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuscaling.py patch to change expected perfomance for ida (2.87 KB, patch)
2008-12-09 18:51 EST, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2008-12-09 16:31:42 EST
Description of problem:
Because the dynamic speed allocation technology of the Nehalem processors allows the processors to run @ a faster than reported speed by disabling the not in use processors the cpuscaling test reports a failure where the SUT shows a +12% gain above in performance than expected (current limit is 10%).

How reproducible:

Every time, run hts-5.2-20 on RHEL5.3 on a Nehalem with Turbo enabled and it'll fail; sometimes under the -xen kernel there are enough other things going on that the turbo boost won't occur.


Additional info:

Current solution is to add 8% speed increase to the expected results and then to the 10% margin of error from there.  Intel PR claims up2 10% speed bump, but there are other things going on inthe system other than cpu clock, so we've and others have averaged around 7-8% effective increase.  Because the margin of error is 10% this should also cover the case where Turbo didn't help though it'll only have a 2% slower window to hit.
Comment 2 Greg Nichols 2008-12-09 18:51:54 EST
Created attachment 326431 [details]
cpuscaling.py patch to change expected perfomance for ida


This test changes expected perfomance by 8% when the "ida" cpu flag is present.
Also, infomation was added to error messages.
Comment 6 Yan Tian 2009-01-24 01:36:01 EST
Tested on gcase-greencity.usersys.redhat.com as below:

- For hts-5.2.20.el5, `hts run -t cpuscaling` failed.
# hts print plan

Test Plan:
----------------------------------------------------------------
usb                   pnp_PNP0a03
cdrom      scd0       storage_model_DVD_SHD_16S1S
cdrom      scd1       storage_model_iHAS120___6
network    eth1       net_00_13_20_f7_56_bd
network    eth0       net_00_13_20_f7_56_bc
memory
video                 pci_10de_421
cpuscaling            acpi_CPU0
core
storage    sda        storage_serial_SATA_Hitachi_HDS7210_GTE205P8GW8R5L

- Upgraded to hts-5.3-15.el5, `hts run -t cpuscaling -v 0` passed, `hts run -t cpuscaling` passed with 16 cpuscaling.
# hts print plan
/var/hts

Test Plan:
----------------------------------------------------------------
usb                   pnp_PNP0a03
dvd        scd0       storage_model_DVD_SHD_16S1S
dvd        scd1       storage_model_iHAS120___6
cdrom      scd0       storage_model_DVD_SHD_16S1S
cdrom      scd1       storage_model_iHAS120___6
network    eth1       net_00_13_20_f7_56_bd
network    eth0       net_00_13_20_f7_56_bc
memory
video                 pci_10de_421
cpuscaling 0          acpi_CPU0
cpuscaling 1          acpi_CPU1
cpuscaling 2          acpi_CPU2
cpuscaling 3          acpi_CPU3
cpuscaling 4          acpi_CPU4
cpuscaling 5          acpi_CPU5
cpuscaling 6          acpi_CPU6
cpuscaling 7          acpi_CPU7
cpuscaling 8          acpi_CPU8
cpuscaling 9          acpi_CPU9
cpuscaling 10         acpi_CPUA
cpuscaling 11         acpi_CPUB
cpuscaling 12         acpi_CPUC
cpuscaling 13         acpi_CPUD
cpuscaling 14         acpi_CPUE
cpuscaling 15         acpi_CPUF
core
storage    sda        storage_serial_SATA_Hitachi_HDS7210_GTE205P8GW8R5L
profiler
info

Verified the bug.
Comment 8 errata-xmlrpc 2009-01-27 17:58:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.