Bug 475664 - scons 0.98.1 won't build ardour
scons 0.98.1 won't build ardour
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: scons (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 18:14 EST by Arnaud Gomes-do-Vale
Modified: 2009-01-04 13:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-04 13:34:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mock config for Planet CCRMA/i386 (1.56 KB, application/octet-stream)
2008-12-19 02:53 EST, Arnaud Gomes-do-Vale
no flags Details
Mock config for Planet CCRMA/x86_64 (1.70 KB, application/octet-stream)
2008-12-19 02:54 EST, Arnaud Gomes-do-Vale
no flags Details

  None (edit)
Description Arnaud Gomes-do-Vale 2008-12-09 18:14:56 EST
Description of problem:

Scons 0.98.1 won't build (recent versions of) ardour. According to http://ardour.org/node/1723 this is a known bug in scons.

Version-Release number of selected component (if applicable):

scons-0.98.1-1.el5

How reproducible:

Always.

Steps to Reproduce:
1. wget http://releases.ardour.org/ardour-2.7.1.tar.bz2
2. tar xjvf ardour-2.7.1.tar.bz2
3. cd ardour-2.7.1
4. scons
  
Actual results:

.../...
g++ -o libs/pbd/base_ui.os -c -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -pipe -DARCH_X86 -mmmx -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -DUSE_X86_64_ASM -Wall -DHAVE_LIBLO -Ilibs -DENABLE_NLS -DHAVE_GETMNTENT -pthread -fPIC -I/usr/include/glib-2.0 -Ilibs/sigc++2 -Ilibs/glibmm2 -I/usr/lib64/glib-2.0/include -Ilibs/pbd -I/usr/include/libxml2 libs/pbd/base_ui.cc
libs/pbd/base_ui.cc: In member function 'int BaseUI::setup_signal_pipe()':
libs/pbd/base_ui.cc:88: error: 'PACKAGE' was not declared in this scope
libs/pbd/base_ui.cc:95: error: 'PACKAGE' was not declared in this scope
libs/pbd/base_ui.cc:101: error: 'PACKAGE' was not declared in this scope
scons: *** [libs/pbd/base_ui.os] Error 1
scons: building terminated because of errors.

Expected results:

Ardour builds without error.

Additional info:

Ardour builds with scons-1.0.0-2.d20080826 (rebuilt from latest Fedora SRPM).
Comment 1 Jochen Schmitt 2008-12-10 10:28:11 EST
I think you should open a bug to tue upstream author.
Comment 2 Arnaud Gomes-do-Vale 2008-12-10 10:36:02 EST
The bug has been fixed upstream in newer releases. At least it is fixed in Fedora development.
Comment 3 Arnaud Gomes-do-Vale 2008-12-10 17:09:34 EST
Whay has this been marked as NOTABUG? Scons is still broken in EPEL 5.
Comment 4 Arnaud Gomes-do-Vale 2008-12-18 14:24:50 EST
I am re-opening the ticket as this is clearly a bug.
Comment 5 Jochen Schmitt 2008-12-18 14:52:04 EST
As far as I understand you want to build ardour agains EPEL-5. I have try to build the package from the cvs devel branch agains EPEL-5 and have got the following error messages from mock:

yes
Checking for gtk+-2.0...
yes
Checking for jack...
no
jack >= 0.109.0 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information
Fehler beim Bauen des RPMS:

I think we should clarify the dependency issue before we may do a update of scons agains EPEL-5-
Comment 6 Jochen Schmitt 2008-12-18 15:10:57 EST
I have done some tests. The results are:

build failded with scons-0.98.1
Build works with scons-0.98.4

So I will suggest, that ew should update scons to 0.98.4 on EPEL-5.

Because are am on vacation for the next two weeks, It may be nice, if we can make this upgrade after my vacation to avoid any issues.

Best Regards:

Jochen Schmitt
Comment 7 Arnaud Gomes-do-Vale 2008-12-18 15:16:36 EST
My bad, I should have given more details.

I build ardour as part of Planet CCRMA. At the moment, the planet provides its
own jack, which is more up-to-date than the one in Fedora (not even considering
EPEL). We ship an updated version of scons, too, but I would prefer if this
could be avoided as I don't need any "new" feature in scons, I just need this
bug fixed.

No problem if you upgrade in a few weeks, in the long run I just would like to avoid superseding packages from EPEL as much as I can.
Comment 8 Jochen Schmitt 2008-12-18 15:26:42 EST
As far as I understand you want to build ardour agains EPEL-5. I have try to build the package from the cvs devel branch agains EPEL-5 and have got the following error messages from mock:

yes
Checking for gtk+-2.0...
yes
Checking for jack...
no
jack >= 0.109.0 not found.
You do not have the necessary dependencies required to build ardour
Please consult http://ardour.org/building for more information
Fehler beim Bauen des RPMS:

I think we should clarify the dependency issue before we may do a update of scons agains EPEL-5-
Comment 9 Jochen Schmitt 2008-12-18 15:27:50 EST
(In reply to comment #7)
> My bad, I should have given more details.
> 
> I build ardour as part of Planet CCRMA. At the moment, the planet provides its
> own jack, which is more up-to-date than the one in Fedora (not even considering

Do you have a mock configuration file which works agains Planet CORMA?

thsi may be very helpful for testing.

Best Regards:

Jochen Schmitt
Comment 10 Jochen Schmitt 2008-12-18 15:36:37 EST
Because the only reason scons was included into EPEL-5 is, that scons is a BR for the blender package which is maintained by myself.

I could successfully check out, that blender will be built fine with scons-0.98.4 at EPEL-5.
Comment 11 Arnaud Gomes-do-Vale 2008-12-19 02:53:36 EST
Created attachment 327416 [details]
Mock config for Planet CCRMA/i386
Comment 12 Arnaud Gomes-do-Vale 2008-12-19 02:54:06 EST
Created attachment 327417 [details]
Mock config for Planet CCRMA/x86_64
Comment 13 Arnaud Gomes-do-Vale 2008-12-19 02:55:10 EST
I have attached the mock config I use on my test buildsystem.
Comment 14 Jochen Schmitt 2009-01-04 13:34:18 EST
I have updated scons to 0.98.4 for EL-5.

I will close this bug now.

Note You need to log in before you can comment on or make changes to this bug.