Bug 475667 - [LTC 6 FEAT] Enhance the ipr driver to support MSI-X interrupt [201780]
[LTC 6 FEAT] Enhance the ipr driver to support MSI-X interrupt [201780]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
low Severity high
: rc
: ---
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-12-09 18:20 EST by IBM Bug Proxy
Modified: 2010-07-20 15:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 17:29:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50582 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 18:20:33 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201780]
a. Name of Feature:	Enhance the ipr driver to support MSI-X interrupt
b. Feature Description
The ipr driver needs to enable the MSI or MSI-X interrupt support for all PCI-Express SAS adapters.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Device Driver
Category:	Device Drivers and IO
Request Type:	Driver - Update Version
d. Upstream Acceptance:	Not Started
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	

3. Business Case
Enhancing the SAS IO on Power platform

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Wayne Boyer, wboyer@us.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 Bill Nottingham 2008-12-10 15:16:47 EST
'Upstream Acceptance: Not Started' is somewhat concerning. What kernel version are you targeting?
Comment 2 IBM Bug Proxy 2009-01-23 12:50:30 EST
The patch has been submitted to linux-scsi here:
http://marc.info/?l=linux-scsi&m=123273106605076&w=2
Comment 3 John Feeney 2009-06-05 14:28:21 EDT
Just an update, patch provided by comment #2 was found upstream with the commit of 5a9ef25b14d39b8413364df12cb8d9bb7a673a32 but is not found in Fedora 11 kernel.
Comment 4 Kevin W Monroe 2009-09-16 17:29:10 EDT
This made it in to 2.6.30.
Comment 5 IBM Bug Proxy 2010-05-13 01:31:37 EDT
------- Comment From wayneb@us.ibm.com 2010-05-13 01:23 EDT-------
Verification efforts with Snap 2 have turned up a problem in sysfs that is preventing the completion of the testing.  The problem is being investigated.
Comment 6 IBM Bug Proxy 2010-05-26 17:51:44 EDT
------- Comment From wayneb@us.ibm.com 2010-05-26 17:44 EDT-------
This problem may be related to the fact that the RHEL 6 kernel is compiled with CONFIG_SCSI_SCAN_ASYNC enabled.   CONFIG_SCSI_SCAN_ASYNC is not enabled in the RHEL 5 releases.
We're looking at whether or not disabling that parameter will make a difference.
Comment 7 IBM Bug Proxy 2010-06-10 11:30:41 EDT
------- Comment From klebers@linux.vnet.ibm.com 2010-06-10 11:24 EDT-------
The bug which the verification of this feature depends on has been fixed but the patch hasn't been accepted and made available on a RHEL6 release yet. Tests with the patch have been completed successfully, however, we are going to wait for a release containing this fix to retest it before closing this feature bugzilla.
Comment 8 IBM Bug Proxy 2010-06-10 13:51:20 EDT
------- Comment From klebers@linux.vnet.ibm.com 2010-06-10 13:43 EDT-------
The blocking bug mentioned in the previous comment is: Bug 63801 - RIT957453- sysfs directories not being created for IPR devices.
Comment 9 IBM Bug Proxy 2010-07-20 15:01:21 EDT
------- Comment From klebers@linux.vnet.ibm.com 2010-07-20 14:50 EDT-------
Confirmed as working as expected on RHEL6 Snap7.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.