Bug 475751 - Website could write data exceed the default max size for offline use
Website could write data exceed the default max size for offline use
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Yolkfull Chow
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 04:48 EST by Yolkfull Chow
Modified: 2008-12-16 08:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 08:53:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The window displaying that computer had been written 175M to storage for offline use (53.45 KB, image/png)
2008-12-15 21:50 EST, Yolkfull Chow
no flags Details

  None (edit)
Description Yolkfull Chow 2008-12-10 04:48:52 EST
Description of problem:
By default, firefox "Use up to 50M of space for the cache" and select option "Tell me when a website asks to store data for offline use". But when a website is writing data exceed the size(50M), although a warning message will popup, the website could write data continuely more than 50M which really may be dangerous to user's computer.

Version-Release number of selected component (if applicable):
firefox-3.0.5-1.el5_2

How reproducible:
Everytime

Steps to Reproduce:
1. visit this website: http://www.campd.org/stuff/tests/offline/offline2.html#
2. click "Accept" for offline test, click "Write 25 megs to offline storage"
3. click "Write a storage value" and "Check storage value"
4. click "Write 25 megs to offline storage" again and again
5. go to Edit->Preferences->Advanced->Network
  
Actual results:
Website could write data more than the max size that firefox set by default.

Expected results:
Could not write data after reaching the max size that user set or by default.

Additional info:
Comment 2 Matěj Cepl 2008-12-15 20:57:56 EST
Cannot reproduce with Firefox on RHEL 5.2 either (firefox-3.0.4-1.el5). Firefox first asks for permission to write offline (which you see as well), and then when twice pressed "Write 25 megs to offline storage", I get an error message saying that the website tried to go over quota. Edit->Preferences->Advanced->Network shows correctly AFAICT 50MB stored.

Closing as WORKSFORME. Reporter, please, show me the way how to reproduce it here.
Comment 3 Yolkfull Chow 2008-12-15 21:50:45 EST
Created attachment 327054 [details]
The window displaying that computer had been written 175M to storage for offline use

would list exact steps as following though I had listed once:

1. click "Allow" when visit the website at first time
2. click "Write 25 megs to offline storage"
3. click "Write a storage value"
4. clcik "Check storage value"
5. click "Write 25 megs to offline storage" twice. At this time, a warning will show that "This website is now storing more than 50M of data on your computer for offline use.", just click on the fork to close
6. click "Write 25 megs to offline storage" again and again until get "error writing data"
7. check the size that has written to storage - 175M, which exceed 50M
Comment 4 Matěj Cepl 2008-12-16 08:53:26 EST
That isn't error -- it doesn't say it will prohibit writing over the limit, but it will warn the user, if he goes over quota. Which it does.

NOTABUG

(if you need quota, you should just do quotas on your filesystem, not trying to persuade to do it)

Note You need to log in before you can comment on or make changes to this bug.