Bug 475762 - Language translation for japanese needs update in anaconda installer
Language translation for japanese needs update in anaconda installer
Status: CLOSED DUPLICATE of bug 474375
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 06:27 EST by Adam Stokes
Modified: 2009-09-21 15:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 09:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partition error in english (57.97 KB, image/jpeg)
2008-12-10 06:27 EST, Adam Stokes
no flags Details

  None (edit)
Description Adam Stokes 2008-12-10 06:27:28 EST
Created attachment 326490 [details]
partition error in english

Description of problem:
During partitioning a warning message is displayed in english when language is set to japanese.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.145

How reproducible:
100%

Steps to Reproduce:
1. Disk format
  # dd if=/dev/zero of=/dev/sda6

2. Make a guest domain
  # virt-install --name=test_vm --ram=1024 --file=/dev/sda6 --vnc --vncport=5949 --keymap=ja --paravirt --location=ftp://xxx.xxxx.xxx/rhel53/x86
   or
  # virt-install --name=test_vm --ram=1024 --file=/dev/sda6 --vnc --vncport=5949 --keymap=ja --hvm --cdrom=/xxx/xxx.iso

3. The installer starts.
3.1 Choose a Language:Japanese

3.2 Select "Input Installation Nunber" and Enter "OK" button.
     or
    Select "Skip entering Installation Number" and Enter "OK" button.
    Enter "Skip" button in Skip screen(Please refert to skip.JPG)

3.3 The installer outputs the warning message(Please refert to warning.JPG)
  
Actual results:
see attached jpg

Expected results:
same message but in selected language

Additional info:
ja.po is not updated though the message was updated in the source.

## anaconda-11.1.2.145 of EL5.3 Beta

partedUtils.py

  1122                 msg = _("The partition table on device %s (%s %-0.f MB) was unreadable.n"
  1123                         "To create new partitions it must be initialized, "
  1124                         "causing the loss of ALL DATA on this drive.nn"
  1125                         "This operation will override any previous "
  1126                         "installation choices about which drives to "
  1127                         "ignore.nn"
  1128                         "Would you like to initialize this drive, "
  1129                         "erasing ALL DATA?") % (drive, dev.model, getDeviceSizeMB (dev),)


po/ja.po

  1829 #: ../partedUtils.py:1009
  1830 #, python-format
  1831 msgid ""
  1832 "The partition table on device %s was unreadable. To create new partitions it "
  1833 "must be initialized, causing the loss of ALL DATA on this drive.n"
  1834 "n"
  1835 "This operation will override any previous installation choices about which "
  1836 "drives to ignore.n"
  1837 "n"
  1838 "Would you like to initialize this drive, erasing ALL DATA?"
  1839 msgstr ""
  1840 "デバイス %s のパーティションテーブルが読み込めませんでした。新規パーティショ"
  1841 "ンを作成するには初期化が必要ですが、本ドライブにあるすべてのデータを失うこと"
  1842 "になります。n"
  1843 "n"
  1844 "この操作を行うと、以前のインストールで選択した無視するドライブの選択をすべて"
  1845 "上書きしてしまいます。n"
  1846 "n"
  1847 "すべてのデータを消去して、このドライブを初期化しますか?"

## anaconda-11.1.2.113 of EL5.2

partedUtils.py

  1028                 msg = _("The partition table on device %s was unreadable. "
  1029                         "To create new partitions it must be initialized, "
  1030                         "causing the loss of ALL DATA on this drive.nn"
  1031                         "This operation will override any previous "
  1032                         "installation choices about which drives to "
  1033                         "ignore.nn"
  1034                         "Would you like to initialize this drive, "
  1035                         "erasing ALL DATA?") % (drive,)

po/ja.po

  1829 #: ../partedUtils.py:1009
  1830 #, python-format
  1831 msgid ""
  1832 "The partition table on device %s was unreadable. To create new partitions it "
  1833 "must be initialized, causing the loss of ALL DATA on this drive.n"
  1834 "n"
  1835 "This operation will override any previous installation choices about which "
  1836 "drives to ignore.n"
  1837 "n"
  1838 "Would you like to initialize this drive, erasing ALL DATA?"
  1839 msgstr ""
  1840 "デバイス %s のパーティションテーブルが読み込めませんでした。新規パーティショ"
  1841 "ンを作成するには初期化が必要ですが、本ドライブにあるすべてのデータを失うこと"
  1842 "になります。n"
  1843 "n"
  1844 "この操作を行うと、以前のインストールで選択した無視するドライブの選択をすべて"
  1845 "上書きしてしまいます。n"
  1846 "n"
  1847 "すべてのデータを消去して、このドライブを初期化しますか?"
Comment 1 RHEL Product and Program Management 2008-12-10 06:51:53 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Denise Dumas 2008-12-10 13:07:57 EST
anaconda is currently being re-translated for BZ 475375.  I have asked them to verify that this string is picked up in the new PO files.
Comment 3 Denise Dumas 2008-12-10 13:14:11 EST
oops - 474375 is the correct BZ
Comment 4 Denise Dumas 2008-12-11 09:19:08 EST
Since updates to 474375 indicate that the completed translations will contain this fix, I am closing this as a duplicate.  Thanks for reporting the problem.

*** This bug has been marked as a duplicate of bug 474375 ***

Note You need to log in before you can comment on or make changes to this bug.