Bug 475771 - K3B crashes on close with libselinux
K3B crashes on close with libselinux
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: k3b-extras (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 07:38 EST by Syam
Modified: 2009-01-10 00:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 00:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 176509 None None None Never

  None (edit)
Description Syam 2008-12-10 07:38:08 EST
Description of problem:
If I install k3b-extras-freeworld package from RPMFusion, K3B crashes on close. The backtrace points to libselinux.so.1.
I had SELinux disabled right after installing Fedora 10.
One of my friends who had SELinux enabled also had the same issue.

How reproducible:
The problem appears after installing k3b-extras-freeworld, and disappears if the package is removed.


Steps to Reproduce:
1. Install k3b-extras-freeworld package from RPMFusion
2. Start K3B
3. Close K3B and notice the crash handler
  

Additional info:
I'm running KDE 4.1.3.
libselinux 2.0.73-1.fc10
libselinux-debuginfo 2.0.73-1.fc10

I had filed a bug report in RPMFusion, and they suggested that the problem is with libselinux. https://bugzilla.rpmfusion.org/show_bug.cgi?id=213
Comment 1 Daniel Walsh 2008-12-10 09:08:35 EST
This is a bug in k3b-extras, probably around memory handling.

libselinux frees memory when the library completes, and some apps have tripped over this, usually because they were careless in their memory handling.
Comment 2 Steven M. Parrish 2009-01-09 13:45:38 EST
This needs to be reported upstream.  Once done please add upstream report info to this report and we will monitor for resolution.
Comment 3 Syam 2009-01-09 22:28:35 EST
Against which updstream project should I file the report? I filed against k3b-extras-freeworld in RPMFusion bug tracker, and they pointed to libselinux, so I filed here.
Should I file against SELinux? Can you please point me to the right bug tracker?
Comment 4 Rex Dieter 2009-01-10 00:15:50 EST
upstream here is bugs.kde.org, against k3b
Comment 5 Syam 2009-01-10 00:30:51 EST
I see you've already posted a comment at KDE bug #176509. Thanks Rex.
Comment 6 Rex Dieter 2009-01-10 00:38:45 EST
Ah, now I remember... :)

Note You need to log in before you can comment on or make changes to this bug.