Bug 475781 - PackageKit icon says "You will need to log off and log back on", but the dropdown menu offers a reboot
PackageKit icon says "You will need to log off and log back on", but the drop...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 477657 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 08:40 EST by Nils Philippsen
Modified: 2008-12-24 12:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 09:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
video illustrating the problem (31.77 KB, video/x-theora+ogg)
2008-12-10 08:41 EST, Nils Philippsen
no flags Details
what's in git (6.26 KB, patch)
2008-12-10 09:47 EST, Richard Hughes
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2008-12-10 08:40:12 EST
Description of problem:
After updating, a PK icon tooltip says "You will need to log off and log back on", but the dropdown menu offers a reboot

Version-Release number of selected component (if applicable):
PackageKit-0.3.11-4.fc10.x86_64

How reproducible:
I haven't tried (you probably need a suitable package update which suggests logging out/in again)

Additional info:
See attached video snippet.
Comment 1 Nils Philippsen 2008-12-10 08:41:26 EST
Created attachment 326509 [details]
video illustrating the problem
Comment 2 Richard Hughes 2008-12-10 09:47:33 EST
Created attachment 326514 [details]
what's in git

I've applied this patch in git which seems to work for me. We had to be a little careful in case the user did two updates, and the second restart type had to be checked to see if it was of greater importance. As this contains a new string, it belongs on the master branch, and will be in the 0.4.1 release. Thanks.
Comment 3 Richard Hughes 2008-12-24 12:49:05 EST
*** Bug 477657 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.