Bug 475795 - Different fallback font used in printed document than on-screen for a missing font
Different fallback font used in printed document than on-screen for a missing...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 10:05 EST by Tim Waugh
Modified: 2009-01-29 18:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here's a copy where I've fixed the names from "Liberation Sans Bold" to a bold-face "Liberation Sans" (154.41 KB, application/vnd.oasis.opendocument.text)
2008-12-10 11:06 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 97127 None None None Never

  None (edit)
Description Tim Waugh 2008-12-10 10:05:13 EST
Description of problem:
When printing a document, an incorrect font is substituted.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.4.2-18.1.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Print attached (private) document.
  
Actual results:
See private attachment.

Expected results:
Should use correct font Liberation, not Nimbus Oblique.
Comment 3 Caolan McNamara 2008-12-10 10:41:53 EST
Um, I see in the source .odt that in a lot of the *RH paragraph styles there are some fonts used with names like "Liberation Sans Bold" with the additional "Bold" feature toggled on. i.e. not "Liberation Sans" with bold toggled on, but an unknown font named "Liberation Sans Bold" if you see what I'm getting at. i.e. the moral equivalent of fc-match "Liberation Sans Bold"
Comment 4 Tim Waugh 2008-12-10 11:06:28 EST
Ah, yes, I see.  Actually for that I get another font:

$ fc-match "Liberation Sans Bold"
DejaVuSans.ttf: "DejaVu Sans" "Book"

...and in fact this seems to be the font that is used on-screen.

Shouldn't this same font be used for print output?
Comment 7 Caolan McNamara 2008-12-11 03:52:49 EST
Logged a patch upstream to register the fontconfig-based fallback system for printing as well. Not sure why we don't already do this, might be some dragons here so checking with upstream about it.
Comment 8 Caolan McNamara 2008-12-11 04:52:23 EST
upstream seems happy enough, committed to F-10 and devel will be in F-10 >= 3.0.0-9.11 when and if there is an F-10 OOo update
Comment 9 Tim Waugh 2008-12-11 05:29:21 EST
Thanks!
Comment 10 Fedora Update System 2009-01-13 03:46:46 EST
openoffice.org-3.0.1-15.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.1.fc10
Comment 11 Fedora Update System 2009-01-14 21:53:44 EST
openoffice.org-3.0.1-15.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0390
Comment 12 Tim Waugh 2009-01-19 05:53:56 EST
Works fine.  Thanks!
Comment 13 Fedora Update System 2009-01-29 18:09:39 EST
openoffice.org-3.0.1-15.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.