Bug 475836 - coreutils is installed too late, breaking installs of other packages
coreutils is installed too late, breaking installs of other packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 13:30 EST by Bruno Wolff III
Modified: 2008-12-10 14:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 13:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-12-10 13:30:46 EST
Description of problem:
When building a live cd there are numerous errors reported about missing commands that are provided by coreutils. These occur before coreutils has been installed.
Presumably those commands don't exist yet in the change root when they are run.
Presumably anaconda has some way to work around this issue and that solution could be borrowed.
While this might be a yum limitation, this won't normally effect people running it because they will already have a version of coreutils installed.

Version-Release number of selected component (if applicable):
livecd-tools-020-1.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1.Run livecd-creator and watch the output
2.
3.
  
Actual results:
Errors reported during the install phase

Expected results:
No errors  Installing: gstreamer                    ################### [ 434/1015] 
  Installing: lincity-ng                   ################### [ 435/1015] 
  Installing: fillets-ng                   ################### [ 436/1015] 
/var/tmp/rpm-tmp.eh9wgo: line 1: touch: command not found
/var/tmp/rpm-tmp.eh9wgo: line 2: /usr/bin/gtk-update-icon-cache: No such file or directory
  Installing: perl-libs                    ################### [ 437/1015] 
  Installing: nc                           ################### [ 438/1015] 
  Installing: redhat-menus                 ################### [ 439/1015] 
  Installing: htmlview                     ################### [ 440/1015] 
  Installing: xblast-data                  ################### [ 441/1015] 
  Installing: perl-Module-Pluggable        ################### [ 442/1015] 
  Installing: shippy-common                ################### [ 443/1015] 
  Installing: ConsoleKit-libs              ################### [ 444/1015] 
  Installing: xorg-x11-drv-vesa            ################### [ 445/1015] 
  Installing: perl-Pod-Escapes             ################### [ 446/1015] 
  Installing: coreutils                    ################### [ 447/1015] 


Additional info:
Here is some sample output from a test games spin build:
Comment 1 Ignacio Vazquez-Abrams 2008-12-10 13:41:40 EST
If those packages need coreutils to run their %pre script then they should have "Requires(pre): coreutils" in their spec. That fact that it works when installing is pure coincidence.
Comment 2 Bruno Wolff III 2008-12-10 14:15:05 EST
Thanks for the specific help. I'll be filing bugs against the appropiate packages.

Note You need to log in before you can comment on or make changes to this bug.