This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 475855 - 5.3-3 forces all tests to be run.
5.3-3 forces all tests to be run.
Status: CLOSED DUPLICATE of bug 472266
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.3
All Linux
high Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 15:03 EST by Adam Sheltz
Modified: 2014-03-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 16:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Sheltz 2008-12-10 15:03:26 EST
Description of problem:
Can not limit what tests get run in version 5.3-3


Version-Release number of selected component (if applicable):


How reproducible:
very


Steps to Reproduce:
1. install 5.3-3
2. #hts plan
3. #hts certify --test memory
  
Actual results:

Do you want to run 
Network, usb, cdrom, storage...
y/n  
Type n and the test will not continue 
Type y and you have to run all the tests....


Expected results:
I expect to be able to run only the tests I select.


Additional info:

I also tried deleting things out of the the mandatory test section of the results.xml and those tests were added back in when I tried to run the test again.
Comment 1 Rob Landry 2008-12-10 16:12:33 EST
"hts certify" in 5.3 picks up some of the missing automation planned in the original design, to run a single test you'll need to use "hts run --test" instead.
Comment 2 Adam Sheltz 2008-12-10 17:05:31 EST
Please confirm, "run" is the key to using the --test option?
Comment 3 Rob Landry 2008-12-10 18:17:10 EST
Confirmed...

hts run --test=memory

-or-

hts run -t memory

...should do what you want.  Note this will still run the info test just as certify did.
Comment 4 Adam Sheltz 2008-12-11 09:35:02 EST

This is more of a documentation issue than a bug. 

Thanks,
Adam
Comment 5 Greg Nichols 2008-12-11 16:24:52 EST

*** This bug has been marked as a duplicate of bug 472266 ***

Note You need to log in before you can comment on or make changes to this bug.