Bug 475915 - ularn is missing post and postun requires for coreutils
ularn is missing post and postun requires for coreutils
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ularn (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 23:13 EST by Bruno Wolff III
Modified: 2009-01-04 01:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 13:44:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-12-10 23:13:24 EST
Description of problem:
The postin and postun scripts run by ularn require coreutils to have already been installed. Not doing this breaks fresh installs and livecd-creator builds.
You should be able to add the following to the spec file:
Requires(post): coreutils
Requires(postun): coreutils

Version-Release number of selected component (if applicable):
I only looked at F10 since that is where I am trying to build a games spin. But the same build was used for F9 so both places should get fixed.
ularn-1.5p4-11.fc9.i386

How reproducible:
The error can be checked by looking at the spec file. The symptoms won't show all of the time somewhat at random based on the install order.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2008-12-18 19:44:40 EST
ularn-1.5p4-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ularn-1.5p4-12.fc10
Comment 2 Fedora Update System 2008-12-21 03:22:32 EST
ularn-1.5p4-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ularn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11603
Comment 3 Fedora Update System 2008-12-24 13:44:52 EST
ularn-1.5p4-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Bruno Wolff III 2009-01-04 01:00:19 EST
Just confirming that I am not seeing the issue any more in F10 nor Rawhide.

Note You need to log in before you can comment on or make changes to this bug.