This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 475973 - Allow installation of bootloader on MBR when /boot is on mdraid1
Allow installation of bootloader on MBR when /boot is on mdraid1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: ---
Assigned To: Hans de Goede
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 06:46 EST by Hans de Goede
Modified: 2009-09-02 05:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Hans de Goede 2008-12-11 06:48:44 EST
We have this fixed in master (Fedora 11), and will soon also have this fixed / allow this in RHEL-4.8, using the same patch as in Fedora, as the involved code has not changed during all that time!

It seems logical to me since this will be both fixed in earlier and later releases to also fix this in RHEL-5.4. All that needs to be done is to apply to already existing patch.
Comment 2 RHEL Product and Program Management 2009-02-03 18:15:06 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Hans de Goede 2009-05-06 08:20:56 EDT
This is fixed in this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=c1ad9ff2601a8f0a27aa9ffc90f32caab0c62f85

Which will be part of the upcoming anaconda-11.1.2.173-1 build.
Comment 7 Alexander Todorov 2009-07-07 09:28:51 EDT
with xen/pv I get:

5.3 ga: 
anaconda.log has:
MBR not suitable as boot device; installing to partition

the system is able to boot.


5.4 latest:
anaconda.log doesn't contain the above message. system is able to boot. 

ks.cfg has:
bootloader --location=mbr

clearpart --all --initlabel
part raid.01 --size=1 --grow --ondisk=xvda
part raid.02 --size=1 --grow --ondisk=xvdb
part swap --size=512 --ondisk=xvdb
part swap --size=512 --ondisk=xvda
raid /   --device=md0 --level=1 --fstype ext3 raid.01 raid.02

Hans,
were you able to reproduce the issue so that the system will not boot as described in the initial comment?
Comment 8 Hans de Goede 2009-07-07 09:50:44 EDT
(In reply to comment #7)
> 
> Hans,
> were you able to reproduce the issue so that the system will not boot as
> described in the initial comment?  

I've not tried reproducing the issue from the original comment, as the faulty
code was present in 5.3 too, I only verified the issue was not present after
the fix.

I think what you might be seeing here is an issue in booty which we fixed recently in Fedora, it seems that even though anaconda tells booty to be installing in to the partition, it still ends up installing on the mbr in case
of /boot leaving on mdraid 1
Comment 9 Alexander Todorov 2009-07-07 10:19:46 EDT
Any idea how to tell if the bootloader is installed on the mbr instead of partition? Can you point me to F11 bug?
Comment 10 Hans de Goede 2009-07-07 13:18:38 EDT
(In reply to comment #9)
> Any idea how to tell if the bootloader is installed on the mbr instead of
> partition?

No, not really, this was discovered by Radek Vykydal, I've added him to the CC.

> Can you point me to F11 bug?

AFAIK there was no F-11 bug, Radek ?
Comment 11 Radek Vykydal 2009-07-08 06:59:22 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > Any idea how to tell if the bootloader is installed on the mbr instead of
> > partition?

Look at first sector of disk (mbr) or partition - it should contain string "GRUB".

# dd if=/dev/sda bs=512 count=1 | hexdump -C

I noticed that we install *always* (in F10, F11, rhel 5.4) on mbr in case of /boot raid 1 partitions, no matter what the user selects (in f10, and also rhel 5.3 I think, there is only option to install on /dev/mdX)

> > Can you point me to F11 bug?
> 
> AFAIK there was no F-11 bug, Radek ?  

I am not sure if there is any specific f11 bug about grub installation for /boot raid 1 partitions.
Comment 12 Alexander Todorov 2009-07-08 09:17:10 EDT
I've repeated the test from comment #7 and did what Radek suggested 
# dd if=/dev/xvda bs=512 count=1 | hexdump -C. The "GRUB" string is visible in the hex output. 

If there are no objections I'll move this one to VERIFIED.
Comment 13 Hans de Goede 2009-07-08 09:31:31 EDT
No objections, as Radek has said it looks like we are doing the wrong thing
when the user asks to actually install on the partition, but that is a different
issue and is an issue in booty, not in anaconda itself.
Comment 15 errata-xmlrpc 2009-09-02 05:55:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.