Bug 475981 - --file HOSTNAME:F doesn't work because rsh is not required when tar is built
--file HOSTNAME:F doesn't work because rsh is not required when tar is built
Status: CLOSED DUPLICATE of bug 294661
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On: 475950
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 07:35 EST by Ondrej Vasik
Modified: 2008-12-17 10:14 EST (History)
2 users (show)

See Also:
Fixed In Version: tar-1.20-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 10:14:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2008-12-11 07:35:12 EST
+++ This bug was initially created as a clone of Bug #475950 +++

Description of problem:

Remote archiving with --file HOSTNAME:F option doesn't work.
The function needs the path for rsh command.
The configure script for tar detects the path.
However, the spec file of tar doesn't require rsh package
in BuildRequire field.

Version-Release number of selected component (if applicable):
1.20-5.fc11 raw hide. But tar shipped with EL4 has the same problem.

How reproducible:

 $ tar -c -f localhost:/tmp/x.tar /boot
 tar: localhost\:/tmp/x.tar: Cannot open: Input/output error
 tar: Error is not recoverable: exiting now

Steps to Reproduce:
1. Just invoke tar with --file HOSTNAME:F argument
2.
3.
  
Actual results:
Reporting an error.

Expected results:
The archive is created at the remote host.

Additional info:

See the patch.

--- Additional comment from yamato@redhat.com on 2008-12-11 04:02:46 EDT ---

Created an attachment (id=326595)
A patch, for spec file of tar, fixing the issue.

--- Additional comment from ovasik@redhat.com on 2008-12-11 07:32:59 EDT ---

Thanks for info and patch (although patch not needed in such cases). Fixed in Rawhide, built as tar-1.20-6.fc11, closing RAWHIDE, will clone bugzilla for RHEL to fix it at least in EL5.
Comment 1 Ondrej Vasik 2008-12-17 10:14:30 EST

*** This bug has been marked as a duplicate of bug 294661 ***

Note You need to log in before you can comment on or make changes to this bug.