This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 475991 - sosreport shouldn't require user input when plug-in diagnoses (potential) error
sosreport shouldn't require user input when plug-in diagnoses (potential) error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Stokes
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 08:41 EST by Ales Zelinka
Modified: 2012-08-21 14:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Although sosreport is designed to run unattended if required to do so, recent versions still prompted users for input during diagnose method tests if the test found any problem. This prompt meant that sosreport was unable to run unattended. Furthermore, when it did not receive a reply to the prompt, sosreport would crash. Sosreport now automatically chooses the option to continue instead of prompting the user whether to continue or not, and can therefore run unattended.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:31:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2008-12-11 08:41:17 EST
Description of problem:
Since "Bug 386691 -  Need unattended way to run sosreport" sosreport should be able to run non-interactively. But when diagnose method finds any problem, it asks the user whether to continue. And ends with traceback because it can't get any answer.


Version-Release number of selected component (if applicable):
sos-1.7-9.2.el5_2.2.noarch

How reproducible:
100%

Steps to Reproduce:
1. trigger any diagnose method in any plug-in during sosreport run
  
Actual results:
traceback when run unattended: 
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=5490009

Expected results:

No traceback, graceful exit.

Additional info:
Comment 9 Ruediger Landmann 2009-09-01 22:11:37 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Although sosreport is designed to run unattended if required to do so, recent versions still prompted users for input during diagnose method tests if the test found any problem. This prompt meant that sosreport was unable to run unattended. Furthermore, when it did not receive a reply to the prompt, sosreport would crash. Sosreport now automatically chooses the option to continue instead of prompting the user whether to continue or not, and can therefore run unattended.
Comment 10 errata-xmlrpc 2009-09-02 03:31:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1418.html

Note You need to log in before you can comment on or make changes to this bug.