Bug 476006 - Corrupted cache file should not cause coolkey to seg fault.
Corrupted cache file should not cause coolkey to seg fault.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coolkey (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Bob Relyea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 10:13 EST by Suzanne Hillman
Modified: 2009-11-18 17:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 17:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-12-11 10:13:01 EST
Description of problem:
Corrupted cache file should not cause coolkey to seg fault. Unclear how the cache file got corrupted in the first place, but it shouldn't cause a seg fault.

Version-Release number of selected component (if applicable):
coolkey-1.1.0-6.el5

How reproducible:
Always, with a corrupted cache file

Steps to Reproduce:
1. Lock screen. Use PIN to unlock.
2. run "certutil -L -h all -d /etc/pki/nssdb" x3
  
Actual results:
First try will not prompt for PIN.
Second try will seg fault.
Third try will prompt for PIN and succeed.

Expected results:
Should always prompt and succeed if correct PIN is used.

Additional info:
Not a regression, since coolkey was not changed in this update.
Comment 1 Chandrasekar Kannan 2009-08-05 15:28:59 EDT
per bug council, shifting to rhel6
Comment 2 RHEL Product and Program Management 2009-08-05 15:31:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2009-11-18 17:37:17 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.