This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 476034 - If NM doesn't know what an AP supports, it should use the 'hidden' connection dialog, but with the selected AP filled in
If NM doesn't know what an AP supports, it should use the 'hidden' connection...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 11:26 EST by Suzanne Hillman
Modified: 2009-11-12 16:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 16:14:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-12-11 11:26:15 EST
Description of problem:
If NM doesn't know what an AP supports, it should use the 'hidden' connection dialog, but with the selected AP filled in. This comes up with the airo and trying to connect to 802.1x WiFi, since ap_scan=2 does not - I believe - obtain what the AP supports, and instead just forces what you tell it to use.

It's very confusing to have a dialog where you cannot select anything for the wireless security method. This ought to be release-noted in 5.3, and fixed in 5.4. 

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-1.el5

How reproducible:
Always, I think

Steps to Reproduce:
1. Get an airo with RHEL5.3 installed.
2. Start NeworkManager
3. Attempt to connect to a visible network using 802.1x WiFi.
  
Actual results:
No options under Wireless Security.

Expected results:
Options available.

Additional info:
Another option would of course be for it to figure it out when you enter whatever security info you have, but that's a long way away.
Comment 1 Dan Williams 2008-12-11 17:52:42 EST
fixed upstream in applet svn r1072 (trunk) and r1073 (0.7 stable)
Comment 2 Dan Williams 2009-11-12 16:14:48 EST
This upstream fix disables the menu item if the device's capabilities aren't compatible with the AP's capabilities.

http://git.gnome.org/cgit/network-manager-applet/commit/?h=NETWORKMANAGER_APPLET_0_7&id=3380003fb810c64e2cbfa1e43526ecb284eed3c0

I don't think that's something we really want to do in RHEL5 at this point, but it's fixed in Fedora and should be in RHEL6 as well.

Note You need to log in before you can comment on or make changes to this bug.