Bug 476052 - [RHEL5.3] i386 paravirt guests are uninstallable on x86_64 dom0
[RHEL5.3] i386 paravirt guests are uninstallable on x86_64 dom0
Status: CLOSED DUPLICATE of bug 472290
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 13:18 EST by Gurhan Ozen
Modified: 2013-11-03 20:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 15:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-12-11 13:18:09 EST
Description of problem:


BUG: unable to handle kernel paging request at virtual address e101c2c0
 printing eip:
c045952a
00ffc000 -> *pde = 00000017:847ff027
BUG: unable to handle kernel paging request at virtual address 15555840
 printing eip:
c061125b
00ffc000 -> *pde = 00000000:00000000
Oops: 0000 [#1]
SMP 
last sysfs file: 
Modules linked in:
CPU:    0
EIP:    0061:[<c061125b>]    Not tainted VLI
EFLAGS: 00010012   (2.6.18-126.el5xen #1) 
EIP is at do_page_fault+0x9df/0xbf9
eax: 00000108   ebx: 15555840   ecx: 0000001a   edx: 55555000
esi: 2101c2c0   edi: 00000017   ebp: c062cec4   esp: c06f1cf0
ds: 007b   es: 007b   ss: e021
Process swapper (pid: 1, ti=c06f1000 task=c06f2aa0 task.ti=c06f1000)
Stack: 00000067 00000010 c06f1d68 c06f2aa0 e101c2c0 00000840 c0ffd840 00000067 
       00000010 00000f45 00717000 c0ffd840 00716000 00ffd027 00000010 85de3067 
       00000017 85de3067 00000017 00000000 c06f1d68 c062ce35 00000000 0000000e 
Call Trace:
 [<c061087c>] do_page_fault+0x0/0xbf9
 [<c0405597>] error_code+0x2b/0x30
 [<c045952a>] page_address+0x6/0x81
 [<c045dd9b>] __handle_mm_fault+0x245/0x11c4
 [<c0450423>] do_generic_mapping_read+0x3d0/0x3d8
 [<c0450c8e>] __generic_file_aio_read+0x166/0x198
 [<c0451d7a>] generic_file_read+0x97/0xab
 [<c045f098>] get_user_pages+0x37e/0x499
 [<c042fdd3>] autoremove_wake_function+0x0/0x2d
 [<c0477b3b>] get_arg_page+0x30/0x7c
 [<c0477cf7>] copy_strings+0xcd/0x173
 [<c0477db6>] copy_strings_kernel+0x19/0x27
 [<c04793d1>] do_execve+0xdf/0x1b2
 [<c040337d>] sys_execve+0x2a/0x4a
 [<c0405413>] syscall_call+0x7/0xb
 [<c0402025>] _stext+0x25/0x3c
 [<c0402093>] init_post+0x57/0xbb
 [<c06f4672>] init+0x247/0x250
 [<c04052ce>] ret_from_fork+0x6/0x1c
 [<c06f442b>] init+0x0/0x250
 [<c06f442b>] init+0x0/0x250
 [<c0403005>] kernel_thread_helper+0x5/0xb
 =======================
Code: 74 08 8b 15 00 74 7a c0 eb 08 a1 20 99 77 c0 8b 14 90 8b 74 24 10 c1 e2 0c 81 e6 ff ff ff 3f 89 f0 c1 e8 15 8d 9c c2 00 00 00 c0 <ff> 33 ff 73 04 52 68 41 cf 62 c0 e8 c3 ee e0 ff 8b 03 83 c4 10 
EIP: [<c061125b>] do_page_fault+0x9df/0xbf9 SS:ESP e021:c06f1cf0
 <0>Kernel panic - not syncing: Fatal exception


Version-Release number of selected component (if applicable):
# rpm -qa | grep xen
xen-devel-3.0.3-79.el5
xen-devel-3.0.3-79.el5
kernel-xen-2.6.18-126.el5
xen-libs-3.0.3-79.el5
xen-debuginfo-3.0.3-79.el5
xen-3.0.3-79.el5
xen-debuginfo-3.0.3-79.el5
kernel-xen-devel-2.6.18-126.el5
xen-libs-3.0.3-79.el5

This is 20081210.nightly tree with the xen packages installed from errata 2009:8014

How reproducible:
Everytime

Steps to Reproduce:
1.  Install RHEL5.3 x86_64 dom0 and try to install a paravirtualized 5.3 guest.
2.
3.
  
Actual results:
Installation crashes.

Expected results:
It shouldn't crash.

Additional info:
# free
             total       used       free     shared    buffers     cached
Mem:      33554432   33423056     131376          0     129024   31473956
-/+ buffers/cache:    1820076   31734356
Swap:      2096440          0    2096440

This is a 32 cpu, AMD system:
processor	: 31
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: Quad-Core AMD Opteron(tm) Processor 8356
stepping	: 3
cpu MHz		: 2300.082
cache size	: 512 KB
physical id	: 31
siblings	: 1
core id		: 0
cpu cores	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall mmxext fxsr_opt lm 3dnowext 3dnow constant_tsc pni monitor cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips	: 5751.95
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc [6] [7] [8]
Comment 1 Ben Levenson 2008-12-11 14:14:59 EST
additional info:
gozen said: was working in the 1204
Comment 3 Bill Burns 2008-12-11 14:35:38 EST
This may be a duplicate of 472290, which was reproducible on RHEL 5.2.
Comment 5 Bill Burns 2008-12-11 15:00:40 EST
This is a duplicate of a known issue that i386 PV guests do not work on a host with over 64 GB. It was also an issue on RHEL 5.2 and thus not a blocker.

*** This bug has been marked as a duplicate of bug 472290 ***

Note You need to log in before you can comment on or make changes to this bug.