Bug 476077 - HP DC7900 won't boot without acpi=off
HP DC7900 won't boot without acpi=off
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 14:58 EST by Michael J. Chudobiak
Modified: 2009-03-16 13:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 18:38:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2008-12-11 14:58:28 EST
My HP DC7900 (their newest business desktop series) won't boot properly unless "acpi=off" is in the grub.conf kernel line.

If that isn't there, tons of acpi errors/backtraces scroll rapidly on the console.

I can get a serial console log if you need it, and tell me how :-)

Linux pekkala 2.6.27.7-134.fc10.x86_64 #1 SMP Mon Dec 1 22:21:35 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

- Mike
Comment 1 Michael J. Chudobiak 2008-12-11 15:41:26 EST
Here are the errors:

Dec  4 08:49:41 localhost kernel: ------------[ cut here ]------------
Dec  4 08:49:41 localhost kernel: WARNING: at arch/x86/kernel/hpet.c:286 hpet_legacy_next_event+0x4e/0x6b() (Tainted: G        W)
Dec  4 08:49:41 localhost kernel: Modules linked in: ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm ppdev snd_timer snd_page_alloc snd_hwdep snd floppy video output pcspkr serio_raw e1000e parport_pc parport tpm_infineon ata_generic tpm tpm_bios pata_acpi wmi soundcore sha256_generic cbc aes_x86_64 aes_generic dm_crypt crypto_blkcipher [last unloaded: microcode]
Dec  4 08:49:41 localhost kernel: Pid: 0, comm: swapper Tainted: G        W 2.6.27.5-117.fc10.x86_64 #1
Dec  4 08:49:41 localhost kernel:
Dec  4 08:49:41 localhost kernel: Call Trace:
Dec  4 08:49:41 localhost kernel: <IRQ>  [<ffffffff810418f2>] warn_on_slowpath+0x60/0x90
Dec  4 08:49:41 localhost kernel: [<ffffffff810597fa>] ? sched_clock_cpu+0x10f/0x120
Dec  4 08:49:41 localhost kernel: [<ffffffff8105a18b>] ? getnstimeofday+0x3a/0x96
Dec  4 08:49:41 localhost kernel: [<ffffffff8105819e>] ? ktime_get_ts+0x49/0x4e
Dec  4 08:49:41 localhost kernel: [<ffffffff810597fa>] ? sched_clock_cpu+0x10f/0x120
Dec  4 08:49:41 localhost kernel: [<ffffffff810310c2>] ? resched_task+0x52/0x8c
Dec  4 08:49:41 localhost kernel: [<ffffffff81020143>] ? apic_wait_icr_idle+0x1a/0x24
Dec  4 08:49:41 localhost kernel: [<ffffffff8105a18b>] ? getnstimeofday+0x3a/0x96
Dec  4 08:49:41 localhost kernel: [<ffffffff81024d85>] hpet_legacy_next_event+0x4e/0x6b
Dec  4 08:49:41 localhost kernel: [<ffffffff8105cb5a>] clockevents_program_event+0x73/0x7c
Dec  4 08:49:41 localhost kernel: [<ffffffff8105dba2>] tick_dev_program_event+0x37/0xa5
Dec  4 08:49:41 localhost kernel: [<ffffffff8105d52b>] tick_handle_oneshot_broadcast+0xc7/0xeb
Dec  4 08:49:41 localhost kernel: [<ffffffff81013626>] timer_event_interrupt+0x1a/0x21
Dec  4 08:49:41 localhost kernel: [<ffffffff8108277f>] handle_IRQ_event+0x33/0x6f
Dec  4 08:49:41 localhost kernel: [<ffffffff81083a85>] handle_edge_irq+0xd6/0x11e
Dec  4 08:49:41 localhost kernel: [<ffffffff8101309e>] do_IRQ+0xf7/0x169
Dec  4 08:49:41 localhost kernel: [<ffffffff81010933>] ret_from_intr+0x0/0x2e
Dec  4 08:49:41 localhost kernel: <EOI>  [<ffffffff811bc6ca>] ? acpi_idle_enter_simple+0x175/0x1b4
Dec  4 08:49:41 localhost kernel: [<ffffffff811bc6c2>] ? acpi_idle_enter_simple+0x16d/0x1b4
Dec  4 08:49:41 localhost kernel: [<ffffffff81285aa3>] ? cpuidle_idle_call+0x95/0xc9
Dec  4 08:49:41 localhost kernel: [<ffffffff8100f279>] ? cpu_idle+0xb2/0x10b
Dec  4 08:49:41 localhost kernel: [<ffffffff8132c875>] ? start_secondary+0x16e/0x173
Dec  4 08:49:41 localhost kernel:
Dec  4 08:49:41 localhost kernel: ---[ end trace 5879870c4b32ddfc ]---
Comment 2 Chuck Ebbert 2008-12-12 00:58:45 EST
That repeated warning has been reduced to just one that prints the first time this happens in kernel 2.6.27.9.
Comment 3 Michael J. Chudobiak 2008-12-12 08:15:01 EST
Is the warning itself important? Or was the repeated nature of it the main problem?

- Mike
Comment 4 Chuck Ebbert 2009-02-19 18:38:22 EST
Looks like it's not a very serious problem.
Comment 5 iztok.stotl 2009-03-16 13:33:41 EDT
(In reply to comment #4)
> Looks like it's not a very serious problem.  

How can you tell ?

Do you have a solution ?

Is it safe to run a computer with acpi = off ?
Comment 6 Michael J. Chudobiak 2009-03-16 13:52:57 EDT
My DC7900 works fine now (and has for some time) with the current kernel, without any special boot parameters.

kernel-2.6.27.15-170.2.24.fc10.x86_64

Closing bug.

- Mike

Note You need to log in before you can comment on or make changes to this bug.