Bug 476118 - Installation problem for python-fedora.noarch 0:0.3.7-1.fc10
Installation problem for python-fedora.noarch 0:0.3.7-1.fc10
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-fedora (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 18:51 EST by NM
Modified: 2008-12-12 12:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 12:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NM 2008-12-11 18:51:08 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

[root@lh ~]# yum install python-fedora.noarch
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package python-fedora.noarch 0:0.3.7-1.fc10 set to be updated
--> Processing Dependency: python-decorator for package: python-fedora
--> Finished Dependency Resolution
python-fedora-0.3.7-1.fc10.noarch from updates has depsolving problems
  --> Missing Dependency: python-decorator is needed by package python-fedora-0.3.7-1.fc10.noarch (updates)
Error: Missing Dependency: python-decorator is needed by package python-fedora-0.3.7-1.fc10.noarch (updates)


Reproducible: Always

Steps to Reproduce:
1.As above
2.
3.
Comment 1 Toshio Ernie Kuratomi 2008-12-12 01:06:00 EST
This is strange, I plainly see python-decorator-2.2.0-1.fc9.noarch.rpm in the Fedora 10 repositories and I can install both it and python-fedora just fine::

$ sudo rpm -e python-fedora python-decorator --nodeps
$ yum install -y python-fedora.noarch
Loaded plugins: allowdowngrade, changelog, downloadonly, fastestmirror,
              : fedorakmod, kernel-module, merge-conf, presto, priorities,
              : protect-packages, protectbase, refresh-packagekit, refresh-
              : updatesd, security, tsflags, versionlock
Setting up and reading Presto delta metadata
No Presto metadata available for updates-testing
No Presto metadata available for livna
No Presto metadata available for fedora
No Presto metadata available for rpmfusion-free-updates
No Presto metadata available for rpmfusion-nonfree-updates
No Presto metadata available for rpmfusion-free
No Presto metadata available for adobe-linux-i386
No Presto metadata available for updates
No Presto metadata available for rpmfusion-nonfree
Loading mirror speeds from cached hostfile
 * updates-testing: mirrors.xmission.com
 * livna: livna.cat.pdx.edu
 * fedora: mirror.lib.ucdavis.edu
 * rpmfusion-free-updates: lordmorgul.net
 * rpmfusion-nonfree-updates: lordmorgul.net
 * rpmfusion-free: lordmorgul.net
 * updates: mirror.lib.ucdavis.edu
 * rpmfusion-nonfree: lordmorgul.net
1564 packages excluded due to repository priority protections
Reading version lock configuration
0 packages excluded due to repository protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package python-fedora.noarch 0:0.3.8-1.fc10 set to be updated
--> Processing Dependency: python-decorator for package: python-fedora
--> Running transaction check
---> Package python-decorator.noarch 0:2.2.0-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch        Version           Repository            Size
================================================================================
Installing:
 python-fedora         noarch      0.3.8-1.fc10      updates-testing      175 k
Installing for dependencies:
 python-decorator      noarch      2.2.0-1.fc9       fedora               134 k

Transaction Summary
================================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 309 k
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
(1/2): python-decorator-2.2.0-1.fc9.noarch.rpm           | 134 kB     00:00     
(2/2): python-fedora-0.3.8-1.fc10.noarch.rpm             | 175 kB     00:00     
--------------------------------------------------------------------------------
Total                                           155 kB/s | 309 kB     00:01     
============================== Entering rpm code ===============================
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : python-decorator                                         1/2 
  Installing     : python-fedora                                            2/2 

=============================== Leaving rpm code ===============================

Installed:
  python-fedora.noarch 0:0.3.8-1.fc10                                           

Dependency Installed:
  python-decorator.noarch 0:2.2.0-1.fc9                                         

Complete!

The above is on an i386 but I verified that the package is in the x86_64 repo as well.  Perhaps this is a problem with the mirror you're getting?
Comment 2 NM 2008-12-12 09:00:07 EST
Thanks for the posting. After reboot I successfully installed the package. I think it is related to PackageKit bug (not sure). As it get fixed this one resolved automatically.
Comment 3 Toshio Ernie Kuratomi 2008-12-12 12:03:30 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.