Bug 476125 - Postinstall script for tomcat5-common-lib rpm builds jar-repositories for javamail, but not java-sasl:
Postinstall script for tomcat5-common-lib rpm builds jar-repositories for jav...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tomcat5 (Show other bugs)
4.9
All Linux
low Severity medium
: rc
: ---
Assigned To: David Knox
qe-baseos-daemons
:
Depends On:
Blocks: 581617
  Show dependency treegraph
 
Reported: 2008-12-11 20:07 EST by Wade Mealing
Modified: 2015-11-01 19:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 581617 (view as bug list)
Environment:
Last Closed: 2010-11-08 10:57:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2008-12-11 20:07:08 EST
Description of problem:

Javamail has java-sasl as a runtime dependancy.  When upgrading tomcat the postinstall script doesn't correctly build all the jar files (with build-jar-repository).  It misses out on java-sasl. 

Version-Release number of selected component (if applicable):

tomcat5-common-lib-5.5.23-0jpp_4rh.

This can be worked around manually with the command.

"build-jar-repository /var/lib/tomcat5/common/lib sasl"

Although I believe it should be in the postinstall section of the tomcat5-common-lib directory to rebuild it where the other jars are being rebuilt.

I have modified the spec file (trivial task), sending up to the relevant engineering person for review.
Comment 2 RHEL Product and Program Management 2009-01-08 20:27:26 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2010-10-22 14:49:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 David Knox 2010-11-08 10:57:25 EST
The tomcat RHEL-4 builds are being phased out. The DevSuite build is unsupported.

Note You need to log in before you can comment on or make changes to this bug.