Bug 476132 - broken package deps
broken package deps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mingw32-gcc (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 22:05 EST by Ralf Corsepius
Modified: 2013-01-09 23:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 14:46:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-12-11 22:05:25 EST
Description of problem:

---> Package mingw32-gcc.x86_64 0:4.3.2-12.fc10 set to be updated
--> Processing Dependency: mingw32-filesystem >= 39-3 for package: mingw32-gcc
--> Processing Dependency: mingw32-w32api for package: mingw32-gcc
--> Processing Dependency: mingw32-cpp for package: mingw32-gcc
--> Processing Dependency: mingw32-runtime for package: mingw32-gcc
--> Processing Dependency: mingw32-binutils for package: mingw32-gcc
--> Running transaction check
---> Package mingw32-gcc.x86_64 0:4.3.2-12.fc10 set to be updated
--> Processing Dependency: mingw32-w32api for package: mingw32-gcc
--> Processing Dependency: mingw32-runtime for package: mingw32-gcc
--> Processing Dependency: mingw32-binutils for package: mingw32-gcc
---> Package mingw32-filesystem.noarch 0:40-2.fc10 set to be updated
---> Package mingw32-cpp.x86_64 0:4.3.2-12.fc10 set to be updated
--> Finished Dependency Resolution
mingw32-gcc-4.3.2-12.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: mingw32-runtime is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)
mingw32-gcc-4.3.2-12.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: mingw32-w32api is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)
mingw32-gcc-4.3.2-12.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: mingw32-binutils is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)
Error: Missing Dependency: mingw32-runtime is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)
Error: Missing Dependency: mingw32-binutils is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)
Error: Missing Dependency: mingw32-w32api is needed by package mingw32-gcc-4.3.2-12.fc10.x86_64 (updates)

Version-Release number of selected component (if applicable):
mingw32-gcc.x86_64 0:4.3.2-12.fc10

How reproducible:
Always

Steps to Reproduce:
1. yum install mingw32-gcc
  
Actual results:
cf. above

Expected results:
Clean install, no broken deps.

Additional info:
How could this have happened?
Comment 1 Richard W.M. Jones 2008-12-12 04:41:22 EST
I think is just because the runtime & w32api packages haven't been moved
into stable yet:

https://admin.fedoraproject.org/updates/mingw32-runtime-3.15.1-10.fc10
https://admin.fedoraproject.org/updates/mingw32-w32api-3.12-8.fc10

If this situation still occurs once they've been pushed, please reopen the
bug and I'll take a closer look.
Comment 2 Ralf Corsepius 2008-12-12 05:09:59 EST
Why are you closing this bug?

This bug has not been fixed. Rel-eng once again, has pushed packages with broken dependencies to the public repos.
Comment 3 Richard W.M. Jones 2008-12-12 05:24:35 EST
I really don't think this is the fault of rel-eng.  We're just waiting for the generated
mingw32-runtime & mingw32-w32api packages to be pushed to stable, and that
will fix the bug.  See comment 1 and
https://fedorahosted.org/rel-eng/ticket/1103
Comment 4 Richard W.M. Jones 2008-12-12 13:34:45 EST
Those two packages have now been moved into stable, which
ought to fix this.  Please try the install again (after
checking the mirror you use has been updated).
Comment 5 Richard W.M. Jones 2008-12-14 14:46:15 EST
https://www.redhat.com/archives/fedora-devel-list/2008-December/msg01477.html
reports no mingw32-related broken deps in F-10, so closing.
Comment 6 Ralf Corsepius 2008-12-15 00:10:18 EST
(In reply to comment #3)
> I really don't think this is the fault of rel-eng.
Repo inconsistencies are always rel-eng's responsibility.

Note You need to log in before you can comment on or make changes to this bug.