Bug 476154 - growisofs will not allow the burning of dual-layer DVD's from an image of less than half the disc's capacity
growisofs will not allow the burning of dual-layer DVD's from an image of les...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 00:17 EST by Peter Fernandes
Modified: 2014-01-12 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:42:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fernandes 2008-12-12 00:17:59 EST
Description of problem:
growisofs will refuse to burn data to a dual-layer DVD if the data is less than 50% of the disc's capacity in size (4GiB), because the extra space on the disc is "wasted."

Version-Release number of selected component (if applicable):
7.0

How reproducible:
Every time.

Steps to Reproduce:
1. Attempt to write less than 4.0GiB of data to a dual-layer DVD (I used k3b as a frontend to growisofs)


  
Actual results:
growisofs complains that too much space will be wasted and exits immediately

Expected results:

The burning continues normally


Additional info:

This is really kind of absurd.  I have no other DVD's but of the dual-layered variety, so I was stopped from burning a disc because someone else decided for me that it was too wasteful.  It's almost certainly the same amount of plastic as a normal DVD...

Here's a patch for growisofs to remove the limitation:
http://repo.calcforge.org/f9/growisofs/growisofs-dvd-dl-undersized.patch
Comment 1 Kevin Kofler 2008-12-12 00:31:40 EST
By the way, the patch comes from openSUSE. Pardus is also carrying it.
Comment 2 Kevin Kofler 2008-12-16 19:40:11 EST
Ping? There's a patch provided and it's trivial.
Comment 3 Fedora Update System 2008-12-17 07:28:08 EST
dvd+rw-tools-7.0-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/dvd+rw-tools-7.0-12.fc9
Comment 4 Kevin Kofler 2008-12-17 12:51:22 EST
Thanks! Can you please also push this to F10?
Comment 5 Fedora Update System 2008-12-21 03:42:02 EST
dvd+rw-tools-7.0-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Kevin Kofler 2008-12-21 04:22:08 EST
What about F10?
Comment 7 Fedora Update System 2009-01-05 09:05:19 EST
dvd+rw-tools-7.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-2.fc10
Comment 8 Fedora Update System 2009-01-07 04:31:59 EST
dvd+rw-tools-7.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.