Bug 476165 - octave crashes for inv(matrice)
octave crashes for inv(matrice)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 02:32 EST by ronald.arvidsson
Modified: 2009-03-19 17:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 10:03:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ronald.arvidsson 2008-12-12 02:32:33 EST
Description of problem:

When trying inv(matrix) any square matrice, octave crashes. All .m programs using this facility crashes for me. Including using the form a/matrix.
Error from crash is 

octave: symbol lookup error: /usr/lib/atlas/liblapack.so.3: undefined 
symbol: ATL_dtrsm

possibly bug in atlas library or octave?

Version-Release number of selected component (if applicable):

octave-3.0.2-2.fc10.i386
atlas-3.6.0-15.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
possibly bug in atlas library instead of octave?
Comment 1 Alex Lancaster 2008-12-12 03:05:49 EST
I can't reproduce this with the new 3.0.3 version of octave in updates-testing:

https://admin.fedoraproject.org/updates/F10/FEDORA-2008-11166

octave: 1> a=[1,1;2,0]
a =

   1   1
   2   0

octave:2> inv(a)
ans =

   0.00000   0.50000
   1.00000  -0.50000

Can you try installing this version, but running as root:

yum --enablerepo=updates-testing install octave

What's also strange is that octave doesn't actually require the atlas package directly, I do also have lapack-3.1.1-4.fc10.i386 installed which may provide similar functionality.
Comment 2 ronald.arvidsson 2008-12-12 04:26:17 EST
Hi,

After installing the 3.0.3 version error disapperas.
Comment 3 Alex Lancaster 2008-12-12 05:44:42 EST
(In reply to comment #2)
> Hi,
> 
> After installing the 3.0.3 version error disapperas.

Thanks, can you add a +1 karma (i.e. "works for me") to the update:

http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11166
Comment 4 Fedora Update System 2008-12-13 10:03:36 EST
octave-3.0.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Parminder Lehal 2009-03-19 17:14:26 EDT
octave: symbol lookup error: /usr/lib/atlas/liblapack

The bug still exists in version 3.0.3 used in 
 2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 athlon i386 GNU/Linux

Below is the output.




GNU Octave, version 3.0.3
Copyright (C) 2008 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTIBILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.

Octave was configured for "i386-redhat-linux-gnu".

Additional information about Octave is available at http://www.octave.org.

Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html

Report bugs to <bug@octave.org> (but first, please read
http://www.octave.org/bugs.html to learn how to write a helpful report).

For information about changes from previous versions, type `news'.

octave:1>  A=[1, 2, 3; 3,  5, 6; 2, 3, 4]
A =

   1   2   3
   3   5   6
   2   3   4

octave:2> det(A)
octave: symbol lookup error: /usr/lib/atlas/liblapack.so.3: undefined symbol: ATL_idamax

Note You need to log in before you can comment on or make changes to this bug.