Bug 476276 - mogstored wont start after upgrade from 1.17 -> 2.20 -- Dependencies missing
mogstored wont start after upgrade from 1.17 -> 2.20 -- Dependencies missing
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mogilefs-server (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 15:43 EST by Clint Goudie
Modified: 2009-02-05 03:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 08:15:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clint Goudie 2008-12-12 15:43:06 EST
Previous to upgrading, I had these mogile rpms installed:

mperl-MogileFS-Client-1.07-2.el5
mogstored-backend-lighttpd-2.17-5.el5
mogstored-2.17-5.el5
perl-MogileFS-Utils-2.12-1.el5
mogstored-backend-apache-2.17-5.el5
mogstored-backend-perlbal-2.17-5.el5
mogilefsd-2.17-5.el5


After upgrading, I had these mogile rpms installed

perl-MogileFS-Utils-2.12-1.el5
mogilefsd-2.20-4.el5
perl-MogileFS-Client-1.07-2.el5
mogstored-backend-perlbal-2.20-4.el5
mogstored-backend-lighttpd-2.20-4.el5
mogstored-2.20-4.el5
mogstored-backend-apache-2.20-4.el5


When starting mogstored I received this error:

service mogstored start
Starting MogileFS tracker daemon: Can't locate Mogstored/HTTPServer/None.pm in @INC (@INC contains: lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /usr/lib/perl5/vendor_perl/5.8.8/mogdeps) at /usr/bin/mogstored line 48.
BEGIN failed--compilation aborted at /usr/bin/mogstored line 48.


a "yum install mogstored-backend-none" solves the problem. Looks like this needs to be added as a dependency to the mogstored core.
Comment 1 Ruben Kerkhof 2009-01-26 08:15:43 EST
Hi Clint,

Sorry this took a while, but it should be fixed in perl-mogilefs-server-2.30, which is in epel-testing now.
Comment 2 Clint Goudie 2009-02-04 16:19:43 EST
Greetings Ruben,

I grabbed the rpms from epel-testing and it appears to be working well for me. How long before those RPMs will show up in the standard EPEL repo?

Thanks!
Comment 3 Ruben Kerkhof 2009-02-05 03:25:05 EST
Hi Clint,

Good to hear it's working for you.
EPEL pushes from -testing to stable happen a bit irregular, but normally once a month.

Note You need to log in before you can comment on or make changes to this bug.