Bug 476286 - ISE when scheduling to deploy rhncfg* packages through Configuration
ISE when scheduling to deploy rhncfg* packages through Configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
: Triaged
Depends On:
Blocks: 462714 479461
  Show dependency treegraph
 
Reported: 2008-12-12 16:01 EST by Jeff Browning
Modified: 2013-01-30 11:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 11:44:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2008-12-12 16:01:04 EST
Description of problem:
When trying to deploy the rhncfg packages to a registered system using the Configuration > Systems > Targets Systems option, an ISE occurs.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Register a system to the 530 Sat
2. Configuration > Systems > Target Systems
3. Select the system and click the Enable RHN Satellite Configuration Management button
  
Actual results:
ISE. Email contents are as follows:

The following exception occurred while executing this request:
POST /rhn/configuration/system/TargetSystemsSubmit.do

Date:12/12/08 3:59:20 PM EST
Headers:
  host: fjs-0-01.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008091816 Red Hat/3.0.2-3.el5 Firefox/3.0.2
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://fjs-0-01.rhndev.redhat.com/rhn/configuration/system/TargetSystems.do
  cookie: JSESSIONID=28B27201FF967B533DDD2D852823B10B; s_cc=true; rh_omni_tc=70160000000H4AjAAK; s_sq=redhatglobaltest%2Credhatqa%3D%2526pid%253Dhttps%25253A//rhn.webqa.redhat.com/rhn/software/channels/All.do%2526oid%253Dfunctiononclick%252528event%252529%25257B%252520%252520toggleRowVisibility%252528%252522id431%252522%252529%25253B%25257D%2526oidt%253D2%2526ot%253DA; s_vi=[CS]v1|4925DB8500002C4F-A3A081A00004693[CE]; rh_sso=0|VryhiBFkftnHT9nBKHYb1xzYeqtclS4NIke; rh_user=jbrownin|Jeff|member; rh_shared_auth=8829cf798189ada21c1f5d82cd5c52ed1bdcd9b0aed0859d6db7448ca5c1b66fb5d2b0dde030f4b0f3917fb8b975485d; pxt-session-cookie=110x1bea66d8437319be0688c9f770ba31ce
  content-type: application/x-www-form-urlencoded
  content-length: 337
  Max-Forwards: 10

Request:
Local Name = fjs-0-01.rhndev.redhat.com
Server Name = fjs-0-01.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@5dec5dec[session=StandardSession[28B27201FF967B533DDD2D852823B10B]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.request.key_size, __sitemesh__filterapplied, javax.servlet.request.ssl_session, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, session, targetSystemsForm, org.apache.struts.action.mapping.instance, requestedUri, org.apache.struts.action.MODULE, 

Form Variables:
  date_year: 2008
  next_lower: 21
  prev_filter_value: 
  last_lower: 1
  use_date: false
  first_lower: 1
  items_selected: 1000010060
  date_month: 11
  prev_lower: 1
  items_on_page: 1000010041
  date_minute: 55
  date_day: 12
  submitted: true
  filter_string: 
  date_hour: 3
  lower: 1
  dispatch: Enable RHN Satellite Configuration Management
  date_am_pm: 1


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: The server architecture (i686) is incompatible with the channel architecture (IA-32)
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
	at java.lang.Thread.run(Thread.java:735)
Caused by: com.redhat.rhn.manager.system.IncompatibleArchException: The server architecture (i686) is incompatible with the channel architecture (IA-32)
	at com.redhat.rhn.manager.system.SystemManager.subscribeServerToChannel(SystemManager.java:1059)
	at com.redhat.rhn.manager.system.SystemManager.subscribeServerToChannel(SystemManager.java:1013)
	at com.redhat.rhn.manager.channel.ChannelManager.subscribeToChildChannelWithPackageName(ChannelManager.java:1294)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystem(EnableConfigHelper.java:108)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystems(EnableConfigHelper.java:85)
	at com.redhat.rhn.manager.configuration.ConfigurationManager.enableSystems(ConfigurationManager.java:1890)
	at com.redhat.rhn.frontend.action.configuration.overview.TargetSystemsSubmitAction.enableSystems(TargetSystemsSubmitAction.java:99)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:59)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:39)
	at java.lang.reflect.Method.invoke(Method.java:612)
	at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:270)
	at org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:187)
	at org.apache.struts.actions.LookupDispatchAction.execute(LookupDispatchAction.java:150)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 40 more

Expected results:
Schedule to deploy files needed to use configuration management on the target system.

Additional info:
Comment 4 Stephen Herr 2013-01-30 11:44:02 EST
I could not reproduce. This is a very old bug, I'm assuming that at some point a duplicate of this bug report was fixed. Closing CurrentRelease.

Note You need to log in before you can comment on or make changes to this bug.