Bug 476343 - RFE: Document how to see other user's desktop via VNC
RFE: Document how to see other user's desktop via VNC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Stephen Wadeley
ecs-bugs
: Documentation, FutureFeature, Reopened
Depends On:
Blocks: 561647
  Show dependency treegraph
 
Reported: 2008-12-13 04:58 EST by Răzvan Sandu
Modified: 2015-07-23 06:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-23 06:38:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-12-13 04:58:15 EST
Description of problem:

Despite the fact there is a good guide about setting a VNC server:

http://fedorasolved.org/network-solutions/vncserver-setup

I was unable to find a good-quality piece of documentation that explains how to set up a stock install of RHEL in order to reach other user's desktop via VNC.

All pieces of documentation that I've found deal with setting a generic VNC server, in order to see a *blank* graphical desktop on a remote system. However, for providing technical support to remote users, it is often necessarry to see *that person's actual desktop*.
  
Actual results:
There is no piece of documentation describing how to (canonical) set up a RHEL box in order to (securely) access other's person desktop via VNC.

Expected results:
Such a piece of documentation should exist.


Thanks a lot,
Răzvan
Comment 4 RHEL Product and Program Management 2010-08-09 15:17:25 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-06-14 06:05:15 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 13 Stephen Wadeley 2015-04-07 03:15:32 EDT
Hello Răzvan


Thank you for raising this bug.



Please see: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/sec-vnc-sharing-an-existing-desktop.html



Thank you

------------------


Red_Hat_Enterprise_Linux-Deployment_Guide-6-en-US-6-5.2
Comment 14 Răzvan Sandu 2015-04-07 12:48:02 EDT
Hello Stephen,

Thanks, that's GREAT, but there is something to be added/clarified:

The command:

x0vncserver -PasswordFile=.vnc/passwd -AlwaysShared=1

must be given *on each ocassion* by an user standing in front of the "receiving" machine or can be used at any time (even *after* a reboot)? In other words, x0vncserver acts as a daemon (can be started automagically started at boot)

Setting a password for access, as a minimum security, is OK, but if the above command must be given explicitly every time when a user wants to receive a VNC session, the situation is less than ideal.

One can easily imagine scenarios in which the receiving user is not present (such as remote assistance & configuration provided by some administrator overnight, via VNC) or is simply not able/not wanting to type such an arcane command (non-technical users, the usual case).

Best regards,
Răzvan
Comment 15 Stephen Wadeley 2015-04-21 11:12:59 EDT
(In reply to Răzvan Sandu from comment #14)
> Hello Stephen,
Hello Răzvan
> 
> Thanks, that's GREAT, but there is something to be added/clarified:
> 
> The command:
> 
> x0vncserver -PasswordFile=.vnc/passwd -AlwaysShared=1
> 
> must be given *on each ocassion* by an user standing in front of the
> "receiving" machine
Yes, if you try it you will see it runs in the terminal, even if you try to background it, and outputs logging messages.

 or can be used at any time (even *after* a reboot)? In
> other words, x0vncserver acts as a daemon (can be started automagically
> started at boot)
> 
> Setting a password for access, as a minimum security, is OK, but if the
> above command must be given explicitly every time when a user wants to
> receive a VNC session, the situation is less than ideal.

Besides the privacy issues, an administrator could connect over SSH, become that user, and then issue the command. 
> 
> One can easily imagine scenarios in which the receiving user is not present
> (such as remote assistance & configuration provided by some administrator
> overnight, via VNC) or is simply not able/not wanting to type such an arcane
> command (non-technical users, the usual case).
I agree the command is not user friendly. Perhaps a desktop icon to run the command would help?
See: https://help.gnome.org/admin/system-admin-guide/2.32/menustructure-desktopentry.html.en

Bare in mind GNOME has vino-server. See https://access.redhat.com/node/16608

I think sharing the users desktop is not required if the user is not present. You could use normal VNC or even SSH when the user is not present.
> 
> Best regards,
> Răzvan

Thank you

Regards
Stephen

Note You need to log in before you can comment on or make changes to this bug.