Bug 476349 - X doesn't set the resolution correctly when using an external LCD screen plus DRI issue on intel 855GM
X doesn't set the resolution correctly when using an external LCD screen plus...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 07:11 EST by Ilyes Gouta
Modified: 2009-03-15 15:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 15:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (18.03 KB, application/x-gzip)
2008-12-13 07:11 EST, Ilyes Gouta
no flags Details
Plain text version of Xorg.0.log (1.08 MB, text/plain)
2008-12-13 07:39 EST, Ilyes Gouta
no flags Details
New Xorg.0.log (working config) (48.61 KB, text/plain)
2008-12-13 18:04 EST, Ilyes Gouta
no flags Details

  None (edit)
Description Ilyes Gouta 2008-12-13 07:11:16 EST
Created attachment 326813 [details]
Xorg.0.log

Description of problem:

X doesn't set the resolution correctly when using my external 19" LCD screen. I boot my Thinkpad R50e (Pentium M, 1.5 GHz) with the external screen connected through the VGA connector. The BIOS picks up the external screen as a primary screen and I get the BIOS messages displayed there. Then Fedora 10 boots (plymouth and al.) and then X starts and sets the screen resolution back to 1024x768 which my laptop's 15" native resolution. Normally X should set the resolution to 1280x1024. GNOME's Screen Resolution tool isn't helpful to set the right configuration.


Version-Release number of selected component (if applicable):

I'm running:
1. Linux kernel 2.6.27.5-117.fc10.i686
2. xorg-x11-server 1.5.3-5.fc10
3. intel as an X driver, version 2.5.0

How reproducible:

Attach an external screen to your laptop and boot X. X will select a non-native resolution.


Additional info:

It's possible to get X to use the native resolution by running in a terminal:
$ xrandr -s 0

Normally a width and a height should be supplied, but that command does the job.
Attached is the Xorg.0.log featuring all the complementary information.
Comment 1 François Cami 2008-12-13 07:22:08 EST
Ilyes,

It seems the Xorg.0.log you've just posted is compressed, and inside it I only get binary stuff.
Could you upload as uncompressed and check that the data is OK ?

Thanks in advance
Comment 2 Ilyes Gouta 2008-12-13 07:39:15 EST
Created attachment 326814 [details]
Plain text version of Xorg.0.log
Comment 3 François Cami 2008-12-13 07:44:32 EST
Thanks, much better.
Comment 4 Ilyes Gouta 2008-12-13 08:44:34 EST
$ glxinfo

name of display: :0.0
[intel_init_bufmgr:592] Error initializing buffer manager.
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, 
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control, 
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.3-devel
OpenGL shading language version string: 1.10
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program, 
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader, 
    GL_ARB_half_float_pixel, GL_ARB_imaging, GL_ARB_multisample, 
    GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_pixel_buffer_object, 
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shader_objects, 
    GL_ARB_shading_language_100, GL_ARB_shadow, GL_ARB_shadow_ambient, 
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression, 
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add, 
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar, 
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat, 
    GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle, 
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, 
    GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos, 
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, 
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array, GL_EXT_convolution, 
    GL_EXT_copy_texture, GL_EXT_depth_bounds_test, GL_EXT_draw_range_elements, 
    GL_EXT_framebuffer_object, GL_EXT_framebuffer_blit, GL_EXT_fog_coord, 
    GL_EXT_gpu_program_parameters, GL_EXT_histogram, GL_EXT_multi_draw_arrays, 
    GL_EXT_packed_depth_stencil, GL_EXT_packed_pixels, 
    GL_EXT_paletted_texture, GL_EXT_pixel_buffer_object, 
    GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal, 
    GL_EXT_secondary_color, GL_EXT_separate_specular_color, 
    GL_EXT_shadow_funcs, GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, 
    GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D, 
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add, 
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, 
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp, 
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, 
    GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_APPLE_vertex_array_object, 
    GL_ATI_blend_equation_separate, GL_ATI_texture_env_combine3, 
    GL_ATI_texture_mirror_once, GL_ATI_fragment_shader, 
    GL_ATI_separate_stencil, GL_IBM_multimode_draw_arrays, 
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat, 
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_program_debug, 
    GL_MESA_resize_buffers, GL_MESA_texture_array, GL_MESA_ycbcr_texture, 
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_fragment_program, 
    GL_NV_light_max_exponent, GL_NV_point_sprite, GL_NV_texture_rectangle, 
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1, 
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table, 
    GL_SGI_texture_color_table, GL_SGIS_generate_mipmap, 
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp, 
    GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow, 
    GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays

3 GLX Visuals
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x21 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x22 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x59 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None

32 GLXFBConfigs:
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x5a  0 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x5b  0 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x5c  0 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x5d  0 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x5e  0 tc  0 32  0 r  .  .  8  8  8  8  0  0  8  0  0  0  0  0 0 None
0x5f  0 tc  0 32  0 r  .  .  8  8  8  8  0  0  8 16 16 16 16  0 0 Slow
0x60  0 tc  0 32  0 r  y  .  8  8  8  8  0  0  8  0  0  0  0  0 0 None
0x61  0 tc  0 32  0 r  y  .  8  8  8  8  0  0  8 16 16 16 16  0 0 Slow
0x62  0 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x63  0 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x64  0 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x65  0 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x66  0 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x67  0 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x68  0 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x69  0 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x6a  0 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x6b  0 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x6c  0 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x6d  0 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x6e  0 dc  0 32  0 r  .  .  8  8  8  8  0  0  8  0  0  0  0  0 0 None
0x6f  0 dc  0 32  0 r  .  .  8  8  8  8  0  0  8 16 16 16 16  0 0 Slow
0x70  0 dc  0 32  0 r  y  .  8  8  8  8  0  0  8  0  0  0  0  0 0 None
0x71  0 dc  0 32  0 r  y  .  8  8  8  8  0  0  8 16 16 16 16  0 0 Slow
0x72  0 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x73  0 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x74  0 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x75  0 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x76  0 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x77  0 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x78  0 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x79  0 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
Comment 5 Ilyes Gouta 2008-12-13 08:46:03 EST
$ rpm -qa xorg-x11-drivers

xorg-x11-drivers-7.3-9.fc10.i386
Comment 6 Ilyes Gouta 2008-12-13 09:29:55 EST
I tried the kernel option nomodeset and it didn't produce any noticeable effect. My external 19" LCD screen now get configured properly on reboot, not because this issue was fixed but mainly because X is storing the last working configuration somewhere and loading it on reboot.

I still have these odd lines in my Xorg.0.log (once I rebooted w/ and w/o the nomodeset option):

(EE) AIGLX error: Calling driver entry point failed(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0

And enabling GNOME's desktop effects using System | Preferences | Look and Feel | Desktop Effects leads to a completely white screen. I can use Ctrl+Alt+Mouse to rotate the cube desktop so that the geometry is there but the texture is somehow corrupted since it's all white. I can press ESC to disable the desktop composition.

The intel driver seems to set the screen depth to 32bit which is OK for alpha blending and desktop composition.

(==) Depth 24 pixmap format is 32 bpp

A long time ago, I reported a similar issue during the F9 days on freedesktop.org, w/ the desktop getting all white when turing on composition and it happened that that issue appeared when setting the screen depth to 16bit and not 32bit. The developers traced the issue back to a bad DRI adversing wrong pixelformats for the different modes. At that time when I set the desktop to 32bit, Compiz and friends (including GNOME's desktop effects) worked flawlessly. It's not the case today with F10.
Comment 7 Ilyes Gouta 2008-12-13 14:44:04 EST
OK, I just updated my F10 and got a new xorg-x11-drv-i810, version 2.5.0-4.fc10 and well, DRI, compiz and desktop effects are working now. :) There is a comment in the change log which says:

Tue Dec  2 23:00:00 2008 Dave Airlie <airlied@redhat.com> 2.5.0-4
- intel-2.5.0-no-gem-legacy3d.patch - enable textures when no GEM

So it definitely had something to do with the recent changes applied to support GEM in intel drivers which at some point corrupted textures. This doesn't fix the original problem which is setting "automagically" the native resolution for external LCD screens.
Comment 8 François Cami 2008-12-13 14:51:34 EST
Nice. Could you post an updated uncompressed Xorg.0.log ?
Thanks in advance.
Comment 9 François Cami 2008-12-13 17:11:55 EST
Switching component to xorg-x11-server (xrandr bug ?).
Comment 10 Ilyes Gouta 2008-12-13 18:04:46 EST
Created attachment 326839 [details]
New Xorg.0.log (working config)
Comment 11 François Cami 2009-02-02 13:28:38 EST
Ilyes,

Can you confirm that the original issue is fixed ? If it is, I'll close this bug.

Thanks
Comment 12 Ilyes Gouta 2009-03-15 15:22:30 EDT
Yes, the original issue is fixed. Sorry for the huge delay.

Regards,
Ilyes Gouta.

Note You need to log in before you can comment on or make changes to this bug.