Bug 476375 - Cannot update setroubleshoot-server
Cannot update setroubleshoot-server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 15:02 EST by Christopher Beland
Modified: 2009-01-24 15:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-24 15:31:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-12-13 15:02:12 EST
I've been running rawhide since Fedora 10.  Today, when I did "yum update python", I got an error:

Error: Missing Dependency: python(abi) = 2.5 is needed by package setroubleshoot-server-2.0.12-3.fc10.noarch (installed)

I have the following selinux-related RPMs installed:

selinux-policy-3.6.1-10.fc11.noarch
selinux-policy-targeted-3.6.1-10.fc11.noarch
setools-console-3.3.5-5.fc11.x86_64
setools-debuginfo-3.3.5-5.fc11.x86_64
setools-libs-3.3.5-5.fc11.x86_64
setroubleshoot-plugins-2.0.11-2.fc11.noarch
setroubleshoot-server-2.0.12-3.fc10.noarch
libselinux-2.0.76-1.fc11.i386
libselinux-2.0.76-1.fc11.x86_64
libselinux-debuginfo-2.0.76-2.fc11.x86_64
libselinux-python-2.0.76-1.fc11.x86_64
libselinux-utils-2.0.76-1.fc11.x86_64

I'm not sure I was supposed to be able to install a version of setroubleshoot-plugins that didn't match the version of setroubleshoot-server.

Anyway, I removed both and then did "yum install setroubleshoot-server setroubleshoot-plugins" which got version 2.0.11-2.fc11 of both.  I note that the fc10 version has a higher number than this, which is perhaps the source of the problem.  I would have expected "yum update" to work without dependency problems that require manual intervention.
Comment 1 Christopher Beland 2009-01-24 15:31:28 EST
Rawhide is now at setroubleshoot-server-2.1.2-1.fc11.x86_64, so I assume this is fixed unless someone retroactively releases something newer to Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.