Bug 476411 - Tab-Completion sound/terminal bell sounds awful now that CONFIG_SND_HDA_INPUT_BEEP is enabled
Tab-Completion sound/terminal bell sounds awful now that CONFIG_SND_HDA_INPUT...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 06:47 EST by Thorsten Leemhuis
Modified: 2008-12-17 11:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 11:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2008-12-14 06:47:00 EST
Description of problem:
Since updating to 2.6.27.9-152.rc2.fc10.x86_64 the terminal bell that for example makes noise when tab-completion in a gnome-terminal is used sounds really awful. Even worse: I can't make it shut up -- I tried to mute the beeper with alsamixer -c 0, but that has no effect :-/

I suppose enabling CONFIG_SND_HDA_INPUT_BEEP is the reason for this new behavior. Is there a way to disable that support during runtime? I looked at http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=1cd2224cd01898a13138f4ab476932cfb689839e and the output from modinfo snd-hda-intel, but could not see anything obvious to disable it.

Version-Release number of selected component (if applicable):
2.6.27.9-152.rc2.fc10.x86_64
Comment 1 Chuck Ebbert 2008-12-15 08:29:12 EST
There should be a new volume control for the beeper. You might have to add it to the default mixer tracks in Gnome, or use alsamixer. 

Also going into the Gnome settings and turning it off should work (the Sounds tab)
Comment 2 Thorsten Leemhuis 2008-12-17 11:14:18 EST
As mentioned or IRC; 2.6.28-0.129.rc8.git2.fc11.x86_64 is able to mute the beeper; I suppose this patch from the 2.6.28-rc is the reason:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4d4e9bb339cfcde7811af10859ba1ce2fe3d46b4

But whatever; you afaics disabled CONFIG_SND_HDA_INPUT_BEEP, so this problem is fixed

Note You need to log in before you can comment on or make changes to this bug.