Bug 476441 - change paths for ffmpeg and x264 libs textrel exceptions
change paths for ffmpeg and x264 libs textrel exceptions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 13:42 EST by Dominik 'Rathann' Mierzejewski
Modified: 2009-11-18 08:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 08:09:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2008-12-14 13:42:17 EST
Sorry to bother you, but I made some changes to ffmpeg and x264 packages in RPMFusion devel branch and the fixes you made for these bugs: bug 469992, bug 470682, bug 471878 and bug 474402 are going to be obsolete, because I moved the libs from /usr/lib/sse2 to /usr/lib/i686. Could you please change the paths in selinux-policy accordingly?
Comment 1 Daniel Walsh 2008-12-15 11:25:56 EST
Can't you just build the libraries correctly so they don't need text relocation then I don't have to make any SELinux changes.
Comment 2 Dominik 'Rathann' Mierzejewski 2008-12-15 13:41:35 EST
Whether it's incorrect to have textrels or not is a subject for debate. ;)
Anyway, x264 has intentionally dropped support for PIC on x86_32, so no, I can't unless someone steps up and offers to maintain a patch adding it back. As for FFmpeg libs, patches are welcome and I can promise I'll work with upstream to get them accepted. Currently, if I force FFmpeg to build with -fPIC, it fails:
/builddir/build/BUILD/ffmpeg-20081214/libswscale/rgb2rgb_template.c: In function 'rgb24toyv12_MMX':
/builddir/build/BUILD/ffmpeg-20081214/libswscale/rgb2rgb_template.c:2221: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
/builddir/build/BUILD/ffmpeg-20081214/libswscale/rgb2rgb_template.c:2148: error: 'asm' operand has impossible constraints
[...]

and

/builddir/build/BUILD/ffmpeg-20081214/libswscale/swscale_template.c: In function 'hcscale_MMX2':
/builddir/build/BUILD/ffmpeg-20081214/libswscale/swscale_template.c:2023: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
/builddir/build/BUILD/ffmpeg-20081214/libswscale/swscale_template.c:1919: error: 'asm' operand has impossible constraints
[...]
Comment 3 Daniel Walsh 2008-12-15 15:28:26 EST
Fixed in selinux-policy-3.5.13-35.fc10
Comment 4 Bug Zapper 2009-06-09 06:16:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.