This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 476452 - 8139too in Fedora 10 KVM guest fails after some transfers
8139too in Fedora 10 KVM guest fails after some transfers
Status: CLOSED DUPLICATE of bug 469859
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 17:14 EST by François Cami
Modified: 2009-02-02 13:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 13:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description François Cami 2008-12-14 17:14:45 EST
Description of problem:
Host is Fedora 10 x86_64 ; guest is Fedora 10 x86_64 in KVM.
After doing some network transfers, either by scp, with iperf, or with nc, the guest loses all network connectivity. Sometimes a "service network restart" will restore the network, most of the time not.


Version-Release number of selected component (if applicable):
kernel-2.6.27.5-117.fc10 ; also tried kernel-2.6.27.9-155.fc10 in both host and guest.


How reproducible:
always after some transfers (it always happens if I try to transfer a 1GB file, it will stall between 30MB and 200MB transferred).


Steps to Reproduce:
1. install a Fedora 10 x86_64 KVM guest in a Fedora 10 x86_64 KVM host
2. scp a 1GB+ file from the host to the guest
3. watch the transfer begin correctly then stall after some time
  
Actual results:
transfer stalls then guest has no network connectivity

Expected results:
transfer succeeds


Additional info:
Switching to another network driver fixes the problem :
"rmmod 8139too" and then either "modprobe 8139cp" or "modprobe e1000".
However, the main problem is that 8139too seems the default driver for KVM guests...
This awfully looks like :
http://www.mail-archive.com/kvm@vger.kernel.org/msg07445.html
Comment 1 François Cami 2009-02-02 13:17:32 EST

*** This bug has been marked as a duplicate of bug 469859 ***

Note You need to log in before you can comment on or make changes to this bug.