Bug 476500 - perl-RPM-Specfile oddity
perl-RPM-Specfile oddity
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Release Test Team
:
Depends On: 484180
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 04:55 EST by Miroslav Suchý
Modified: 2009-03-31 14:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 14:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-12-15 04:55:44 EST
Description of problem:
Package perl-RPM-Specfile has branches for RHEL[45] and is built for this release as well:
 https://brewweb.devel.redhat.com/buildinfo?buildID=42399
But is not included in RHEL release (neither 5Server nor 5Client nor 4AS).

Can you please either cancel those rhel[45] branches so the package can be build in epel. Or you can fix the composes and include the package in RHEL[45] release?
Comment 1 Jan Pazdziora 2008-12-15 05:01:28 EST
I wonder how urgently we need that package (for Spacewalk). It seems it is only used by the /usr/bin/satcon-make-rpm.pl script in perl-Satcon and even there, plain printing to the output .spec file should work just fine.
Comment 2 Dennis Gregorovic 2009-02-03 10:55:30 EST
Have you decided if you need this package or not?  Also, do the internal RHEL-4 and RHEL-5 branches actually preclude EPEL inclusion?
Comment 3 Miroslav Suchý 2009-02-03 11:07:03 EST
Yes, we need need it.
Comment 5 Miroslav Suchý 2009-02-04 04:53:19 EST
After quick disscussion with perl-RPM-Specfile (mmaslano@redhat.com) we come to conclusion that this package should be in both RHEL 4 and RHEL 5. Can you put it to composes and include the package in RHEL[45] release?
Comment 7 Miroslav Suchý 2009-02-05 04:42:21 EST
I would like to see it in RHEL since we need it for RHN Satellite. And the presence of RHEL branch and not availability in RHEL cause us problem. 
Raising the priority.
Comment 8 Jan Pazdziora 2009-02-05 05:12:20 EST
-1.

We don't need this. The only place where we use the thing is satcon-make-rpm.pl in perl-Satcon, and that can easily be rewritten by not using the RPM::Specfile module at all.

Plus, if the package is suddenly in RHEL, and we still ship it with RHN Satellite (the package will still be on already-released ISOs), we might be for a version conflict.

The correct solution is to rewrite perl-Satcon not to use RPM::Specfile.
Comment 9 Jan Pazdziora 2009-02-05 05:13:42 EST
Hmmm. The script satcon-make-rpm.pl is not used anywhere in Satellite, and as a matter of fact, it is no longer shipped in perl-Satcon (I removed it from its .spec file).

So it's like -2.
Comment 10 Marcela Mašláňová 2009-02-19 10:16:29 EST
It was decided this package won't be needed in RHEL. This will be created in EPEL.

Could you remove those branches in RHEL, if it's needed for branching in EPEL?
Comment 11 Dennis Gregorovic 2009-02-19 10:33:49 EST
Removing the branches in RHEL won't be necessary for building in EPEL.  Feel free to proceed with the EPEL inclusion.
Comment 12 Jan Pazdziora 2009-02-19 10:56:42 EST
Dennis, I believe we don't really need nor want that package in EPEL, at this point anyway.

This bugzilla can be closed.

Sorry for the confusion.

Note You need to log in before you can comment on or make changes to this bug.