Bug 476503 - Introspect error on :1.0:/org/freedesktop/Hal/Manager: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied
Introspect error on :1.0:/org/freedesktop/Hal/Manager: dbus.exceptions.DBusEx...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 05:27 EST by Robert Scheck
Modified: 2009-01-09 11:11 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.2.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 11:11:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file with the errors visible on console (128.77 KB, text/plain)
2008-12-15 05:27 EST, Robert Scheck
no flags Details
output from terminal (133.03 KB, text/plain)
2008-12-16 16:51 EST, Chris Linville
no flags Details

  None (edit)
Description Robert Scheck 2008-12-15 05:27:10 EST
Created attachment 326928 [details]
Log file with the errors visible on console

Description of problem:
Since the everything breaking dbus update, I've lots of nice error messages
and exceptions when starting system-config-display on Fedora 10

Version-Release number of selected component (if applicable):
system-config-display-1.1.1-1.fc10

How reproducible:
Everytime with an up-to-date system with updates except updates-testing.

Actual results:
Lots of dbus specific error messages.

Expected results:
Working stuff without errors etc. as before the dbus update.

Additional info:
The message, I'm seeing on the console are attached as file hereby.
Comment 1 Chris Linville 2008-12-16 16:51:15 EST
Created attachment 327173 [details]
output from terminal
Comment 2 Chris Linville 2008-12-16 16:51:29 EST
Fedora 10
2.6.27.7-134.fc10.i686

system-config-display would not open.  running it from a terminal produced this:

ERROR:dbus.proxies:Introspect error on :1.0:/org/freedesktop/Hal/devices/pci_8086_2658: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.0")

There is more.  I can upload it if I can figure out how.  Once I ran nvidia-xconfig I was able to run system-config-display but there are still tons of dbus exceptions.
Comment 3 Chris Linville 2008-12-16 16:57:17 EST
Sorry.  System was up to date as of time of the post.  The errors are reproducible everytime i run system-config-display from a terminal.  

Run from the gui I do not see the errors, but it takes a while for config-display to come up.
Comment 4 Gianluca Varisco 2008-12-24 09:00:44 EST
Chris,

A dbus update has been pushed out more than one week ago. Would you please attach there the output of this command:

# rpm -qa dbus*

Thanks.
Comment 5 Chris Linville 2009-01-09 11:04:26 EST
Sorry computer with issues was at work.  Just got back from vacation.  updated.  Error is gone.

dbus-1.2.4-2.fc10.i386
dbus-x11-1.2.4-2.fc10.i386
dbus-python-0.83.0-3.fc10.i386
dbus-libs-1.2.4-2.fc10.i386
dbus-glib-0.76-3.fc10.i386

Thanks for the assistance.
Comment 6 Robert Scheck 2009-01-09 11:11:26 EST
You're right, closing now.

Note You need to log in before you can comment on or make changes to this bug.