This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 476532 - Problem with crash version on MRG 1.1
Problem with crash version on MRG 1.1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.1
x86_64 All
low Severity medium
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
David Sommerseth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 08:41 EST by IBM Bug Proxy
Modified: 2016-05-22 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 15:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-12-15 08:41:20 EST
=Comment: #0=================================================
Amrith Anandan <amrith.anandan@in.ibm.com> - 
While doing kmem -i on a MRG 1.1 box with crash 4.0-5.0.3 gives some warnings. After upgrading the
crash with the latest one, kmem -i gives no warnings


Scenario
project : MRG 1.1 
Machine : llm65
Task : Kdump Testing


With the crash version 4.0-5.0.3

 kmem: invalid structure member offset: address_space_nrpages
 FILE: memory.c  LINE: 6624  FUNCTION: nr_blockdev_pages()
 [/usr/bin/crash] error trace: 465762 => 46e932 => 46f4b5 => 500452
 /usr/bin/nm: /usr/bin/crash: no symbols
/usr/bin/nm: /usr/bin/crash: no symbols
 /usr/bin/nm: /usr/bin/crash: no symbols
 /usr/bin/nm: /usr/bin/crash: no symbols
 WARNING: Because this kernel was compiled with gcc version 4.1.2, certain
 commands or command options may fail unless crash is invoked with
 the  "--readnow" command line option.
 FILE: memory.c  LINE: 6624  FUNCTION: nr_blockdev_pages()

After the updated version of crash.

[root@llm65 crash-4.0-7.5]# crash -v

crash 4.0-7.5


crash> kmem -i
              PAGES        TOTAL      PERCENTAGE
      TOTAL MEM  4012128      15.3 GB         ----
      FREE  3943626        15 GB   98% of TOTAL MEM
      USED    68502     267.6 MB    1% of TOTAL MEM
      SHARED     5674      22.2 MB    0% of TOTAL MEM
     BUFFERS     3331        13 MB    0% of TOTAL MEM
     CACHED    37608     146.9 MB    0% of TOTAL MEM
      SLAB     6522      25.5 MB    0% of TOTAL MEM

TOTAL SWAP   524118         2 GB         ----
 SWAP USED        0            0    0% of TOTAL SWAP
 SWAP FREE   524118         2 GB  100% of TOTAL SWAP

--- Amrith
Comment 1 IBM Bug Proxy 2009-06-10 17:40:26 EDT
------- Comment From vernux@us.ibm.com 2009-06-10 17:35 EDT-------
Amrith,

Where did you get the version of crash?  Did you just download the source and compile/install yourself or did you find an RPM somewhere.

We need more specific instructions for the customer.
Comment 2 IBM Bug Proxy 2009-06-11 01:30:26 EDT
------- Comment From amrith@linux.ibm.com 2009-06-11 01:26 EDT-------
(In reply to comment #14)
> Amrith,
>
> Where did you get the version of crash?  Did you just download the source and
> compile/install yourself or did you find an RPM somewhere.
>
> We need more specific instructions for the customer.
>

Vernon,

Once i ran the crash on the dump created by the kdump testing, i got the symbol mismatch error. Then i did a "man crash", the crash home page was mentioned in the last section. I went into the site and downloaded the latest crash mentioned there.
Comment 3 IBM Bug Proxy 2009-06-15 02:00:33 EDT
------- Comment From amrith@linux.ibm.com 2009-06-15 01:55 EDT-------
When i filed the bug itself, I have pointed out the solution. So it is a matter of versions.
Comment 4 IBM Bug Proxy 2009-06-29 09:21:49 EDT
------- Comment From sripathik@in.ibm.com 2009-06-29 09:14 EDT-------
To RH:

We have closed this bug on IBM bugzilla. We have documented the problem with crash that ships with RHEL5.2.

Note You need to log in before you can comment on or make changes to this bug.