Bug 476566 - XFCE login hangs at "starting gnome-keyring-daemon"
XFCE login hangs at "starting gnome-keyring-daemon"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 13:27 EST by Clark Williams
Modified: 2009-05-13 10:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 10:57:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps axf output while xfce login was hung (8.03 KB, text/plain)
2008-12-15 13:29 EST, Clark Williams
no flags Details

  None (edit)
Description Clark Williams 2008-12-15 13:27:52 EST
Description of problem:
Logging into XFCE via GDM started hanging on my rawhide installation (x86_64 on a T60 laptop). The XFCE splash screen would display "Starting gnome-keyring-daemon" and just stop.

Switching to VT2 and logging in via the console, I could see that there were multiple instances of gnome-keyring-daemon started (see attached ps axf output).  Issuing a 'killall gnome-keyring-daemon' would allow the login process to continue and normal operation from that point (something must have started g-k-d after that, because it was running and nm-applet/NetworkManager got keys to join wireless networks properly). 

I eventually set the xfce4-session settings to *not* start gnome-services and was able to successfully login without extra gyrations. 


Version-Release number of selected component (if applicable):
xfce4-session-4.4.2-4.fc10.x86_64
Comment 1 Clark Williams 2008-12-15 13:29:02 EST
Created attachment 327002 [details]
ps axf output while xfce login was hung

This is the output of 'ps axf' while the login was hung
Comment 2 Kevin Fenzi 2008-12-16 01:01:12 EST
Strangely, I see here with F10 that there are 2 of them running as well, but everything works ok. 

I wonder if it was always running multiple copies before, but now they are not playing nice together?

Will try and dig some more to see whats going on here.
Comment 3 Clark Williams 2009-01-05 13:16:32 EST
This went away for a while and now it's back on my rawhide laptop. When I login from gdm, the XFCE splash screen announces that it's starting gnome-power-manager and we stop until I go over to vt2 and issue a 'killall gnome-power-manager'. Startup continues after that and yes, gnome-power-manager is running when the startup sequence finishes.
Comment 4 Clark Williams 2009-01-07 15:31:42 EST
looks like it's when the "Launch GNOME services on startup" box is checked in the session manager gui that this happens. Unchecking that box gets past the hang. 

Oh and I'm an idiot. The hang occurs when starting gnome-keyring-daemon, not gnome-power-manager (was debugging a g-p-m problem earlier, sorry for the confusion).
Comment 5 Kevin Fenzi 2009-01-11 13:09:27 EST
Yeah, I can duplicate this here now. 

It looks like gnome-keyring might be setup now to launch via dbus when it's needed, so I guess Xfce shouldn't launch it in it's session anymore. 

And, looking at the 4.6beta2 code for this, it now checks to see if one is running and uses that instead of just trying to start one. 

So, this should go away once the 4.6beta2 stuff lands.
Comment 6 Christoph Wickert 2009-04-17 14:46:10 EDT
A cannot reproduce this bug. Clark, ist this still valid?
Comment 7 Clark Williams 2009-04-17 14:59:16 EDT
I had to drop back to F10 (kernel issue, not XFCE) and haven't gone back to rawhide yet, so I haven't tried duplicating the problem in a while. 

Might as well close it. If I run into it when I go back to rawhide, I'll open another.
Comment 8 Christoph Wickert 2009-04-17 15:29:21 EDT
If you are still on F10, you could try Kevin's repo at
http://www.scrye.com/~kevin/fedora/xfce46/
Comment 9 Kevin Fenzi 2009-05-11 02:23:44 EDT
Any news here? Do you see the issue with 4.6.1 in rawhide?
Comment 10 Clark Williams 2009-05-13 10:37:58 EDT
I have been unable to reproduce this bug in latest rawhide. I'd say close it.
Comment 11 Christoph Wickert 2009-05-13 10:57:57 EDT
Your wish is my command.

Note You need to log in before you can comment on or make changes to this bug.