Bug 476568 - LOCALDOMAIN environment variable no longer works in F10 with nscd running
LOCALDOMAIN environment variable no longer works in F10 with nscd running
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 14:14 EST by Colin.Simpson
Modified: 2008-12-29 16:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 14:56:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin.Simpson 2008-12-15 14:14:14 EST
Description of problem:
If you set the environment variable LOCALHOST it is supposed to override the system default search path. It doesn't, you simply get the system search path from resolv.conf if nscd is running.

How reproducible:

Everytime

Steps to Reproduce:
1. Ensure nscd is running. Then Set 

export LOCALDOMAIN="notsearch.com. orginaldomain.com."

and only have 

search orginaldomain.com.

, in resolv.conf

2. telnet to say a webserver "testwww" on a machine that is only in notsearch.com

3. telnet testwww 80
  
Actual results:

On F10 you get,

telnet: testwww: Name or service not known

On F9 you get,

telnet testwww 80
Trying 192.168.5.47...
Connected to testwww
Escape character is '^]'.

Additional info:

Works if nscd is stopped. Actually there is a more subtle bug (maybe a feature) in earlier nscds, which is probably still there in F10 if this bug was not masking it. I've just noticed. Before consulting the LOCALDOMAIN flag it seems to always consult nscd's system default path before trying LOCALDOMAIN. This seems to be in RHEL 4 and 5 so I'll probably log a separate bug report on that.
Comment 1 Ulrich Drepper 2008-12-29 14:56:09 EST
That's the expected behavior.
Comment 2 Ulrich Drepper 2008-12-29 16:02:34 EST
Even if it is the expected behavior I added a work-around which can help in some situations.  It will fail if nscd is running because ordinary processes cannot perform lookups.

It will appear in the next build.

Note You need to log in before you can comment on or make changes to this bug.