Bug 476575 - epdfview crashes on print pdf
epdfview crashes on print pdf
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: epdfview (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
http://trac.emma-soft.com/epdfview/ti...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 15:23 EST by Edwin ten Brink
Modified: 2009-01-14 22:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:11:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Information collected by Bug Buddy. (290.29 KB, text/plain)
2008-12-15 15:24 EST, Edwin ten Brink
no flags Details
crash manager's bug report (349.95 KB, text/plain)
2008-12-17 03:10 EST, Mark Summerfield
no flags Details

  None (edit)
Description Edwin ten Brink 2008-12-15 15:23:20 EST
Description of problem:
epdfview crashes when trying to print a PDF document.

Version-Release number of selected component (if applicable):
$ rpm -q epdfview
epdfview-0.1.6-4.fc10.i386

How reproducible:
Always.

Steps to Reproduce:
1. Open any PDF file.
2. Select File -> Print
  
Actual results:
Crash.
Information collected by Bug Buddy is attached.

Expected results:
Print dialog.

Additional info:
Upstream has this bug on file in their tracking system since 2006-06-17, but has taken no action whatsoever, see http://trac.emma-soft.com/epdfview/ticket/41. Is this project still alive?

Since Fedora has no other lightweight PDF viewer, I would much appreciate anything Fedora can do in this case.
Comment 1 Edwin ten Brink 2008-12-15 15:24:31 EST
Created attachment 327019 [details]
Information collected by Bug Buddy.
Comment 2 Mark Summerfield 2008-12-17 03:10:27 EST
Created attachment 327210 [details]
crash manager's bug report

Just to confirm that printing crashes epdfview for me too as the attached bug report shows.
Comment 3 Fedora Update System 2008-12-17 15:02:54 EST
epdfview-0.1.6-6.20081217svn.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/epdfview-0.1.6-6.20081217svn.fc10
Comment 4 Fedora Update System 2008-12-17 15:07:17 EST
epdfview-0.1.6-6.20081217svn.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/epdfview-0.1.6-6.20081217svn.fc9
Comment 5 Michal Schmidt 2008-12-17 16:36:29 EST
I added one more change to have the menu icon shown, so the URLs are now:
https://admin.fedoraproject.org/updates/epdfview-0.1.6-7.20081217svn.fc10
https://admin.fedoraproject.org/updates/epdfview-0.1.6-7.20081217svn.fc9
Comment 6 Edwin ten Brink 2008-12-18 15:09:36 EST
I've tested epdfview-0.1.6-7.20081217svn.fc10 with a couple of PDF's which all were sent to the printer without crashing.

Also the correct menu icon appears.

As far as my report is concerned, you can release this update and close this bug. Thanks!
Comment 7 Michal Schmidt 2008-12-18 16:29:40 EST
Thank you for reporting and testing. I'll leave the package in updates-testing for a few days and then push it to stable if no regressions are found.
Comment 8 Fedora Update System 2008-12-21 03:20:09 EST
epdfview-0.1.6-7.20081217svn.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update epdfview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11473
Comment 9 Fedora Update System 2008-12-21 03:28:37 EST
epdfview-0.1.6-7.20081217svn.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update epdfview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11435
Comment 10 Fedora Update System 2009-01-07 04:11:39 EST
epdfview-0.1.6-7.20081217svn.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-01-14 22:05:48 EST
epdfview-0.1.6-7.20081217svn.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.