Bug 476625 - NetworkManager Edit Connection window crashes when setting connection by hand
NetworkManager Edit Connection window crashes when setting connection by hand
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 05:31 EST by Vladimir Benes
Modified: 2011-09-29 06:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:29:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2008-12-16 05:31:11 EST
Description of problem:
if you do not have DHCP server you are unable to set it via NM because the settings window crashes all the time when filling in NetMask

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-2.el5
NetworkManager-gnome-0.7.0-2.el5
NetworkManager-glib-0.7.0-2.el5

How reproducible:
100%

Steps to Reproduce:
1.right click on NM applet
2.click "Edit connections.."
3.click "Add" to add new profile 
4.go to "IPv4 Settings" tab
5.change Method to manual
6.click "Add" to add new IP Address
7. when changing to field NetMask CPU goes to 100% and settings editor crashes
  
Actual results:
crash

Expected results:
do not crash

Additional info:
I don't know if this is a regression because I do not have older 5.3 or 5.2 installed 
I finally managed to fill all items by clicking to other window when I am finished with filling of each item.. nm editor change the field by clicking to another window which is also quite strange
Comment 1 Vladimir Benes 2008-12-16 05:38:49 EST
comment to description: you are unable to set network connection via NM (that "it" seems to be connected to dhcp in that context I think :] )
Comment 6 Dan Williams 2008-12-16 16:56:32 EST
Have a simple fix that disables the problem code for moving focus to the next edit cell in the address list; user needs to click the next field manually now, but it's certainly better than infinite recursion + segfault.
Comment 7 Dan Williams 2008-12-16 16:56:58 EST
Have a simple fix that disables the problem code for moving focus to the next
edit cell in the address list; user needs to click the next field manually now,
but it's certainly better than infinite recursion + segfault.
Comment 11 wang jiabo 2008-12-17 01:57:59 EST
I test on the 5.3 with kernel 2.6.18-122.el5 kernel, and
 NetworkManager used NetworkManager-0.7.0-0.11.svn4185.el5
                    NetworkManager-gnome-0.7.0-0.11.svn4185.el5
                    NetworkManager-glib-0.7.0-0.11.svn4185.el5.
it is no problem.
I upgrade the NetworkManager with the same kernel to
 NetworkManager-0.7.0-2.el5
 NetworkManager-gnome-0.7.0-2.el5
 NetworkManager-glib-0.7.0-2.el5

 I did the steps according to the bug , when I finished to
 input the ipv4 address and want to input ipv4 netmask, then the window
 disappear.


I reinstall my OS to the latest 5.3 with kernel 2.6.18-126.el5.
I reproduce the problem with the same environment. 
 but there is a little difference. 
 my cpu up to from 0.3% to 47%, no 100%.
Comment 24 errata-xmlrpc 2009-01-20 16:29:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0161.html

Note You need to log in before you can comment on or make changes to this bug.