Bug 476670 - Fedora 10 is so AWFUL that I am filing a General Complaint...too many problems to list
Fedora 10 is so AWFUL that I am filing a General Complaint...too many problem...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 10:10 EST by Shaun Andrew
Modified: 2008-12-16 17:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 10:30:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaun Andrew 2008-12-16 10:10:29 EST
Description of problem:

initrd cannot boot from SCSI drive after installation
cannot retain network settings from one reboot to the next
NetworkManager is a Real LOOSER.
KDE's Kate Editor cannot retain its configuration settings either
Printer setup cannot setup or find a network printer that I can "ping"
Printer setup does not allow manual entry of a printer's IP address
ATI radeon video cannot load DRI ... screens are sluggish
fdisk does not list drives unless the drives are in fstab
etc
etc
etc


Fedora 9 was not so great either.  Fedora is becoming more and more useless with each release.  I am an Electrical Engineer and Software Developer for several US NAVY Flight Instrument Trainers (FITs), i.e., flight simulators.  Over the past 10 years many FITs have been rehosted from proprietary computer systems with proprietary Operating Systems to PCs using Linux and Open Source where Redhat and Fedora have dominated.  Prior releases of Redhat, as well as releases of Fedora up to Fedora 8, have provided stable and flexible system configurations due to their strengths and agility to facilitate development.

NOW FEDORA IS NO LONGER STABLE, MUCH LESS FLEXIBLE.  From a Developer's and Engineer's standpoint Fedora is finished.  It is now time for Developers and Engineers to move to another Linux Distribution, which is shame when one has so much already vested.



Version-Release number of selected component (if applicable):
TOO MANY INTOLERABLE COMPONENTS TO LIST.

How reproducible:
JUST INSTALL FEDORA 10 AND CRY.

Steps to Reproduce:
1. INSTALL
2. TRY TO CONFIGURE SOMETHING
3. COMPLAIN TO FEDORA PROJECT
  
Actual results:
NOTHING CAN BE CONFIGURED ... ESPECIALLY NETWORKS
So many problems that it leads to frustration and anxiety as developers realize that they must now learn to develop under a new Linux Distribution and loose all  that they have vested in Fedora 

Expected results:
That each release of Fedora will improve.  Offering more stability, improvements in configuration, developer flexibility, better video, and etc, etc, etc.

Additional info:
I am exploring the possibility of migrating to Debian.
Comment 1 Hans de Goede 2008-12-16 10:30:50 EST
Your booting from scsi disks not working is a known (and very regretable issue), see bug 466607. As for the rest, well thats not an mkinitrd issue and you really should know better then to put multiple issues in one bug.
Comment 2 Jim Wildman 2008-12-16 17:14:18 EST
I've used Red Hat since 1995, have passed the RHCE twice and 2 of the RHSA tests and make my living supporting RHEL systems.  Fedora 10 is the first release that I gave up on.  You've worked hard to create a large user base.  Why repeat other's mistakes by breaking assumptions????

I did not try to find answers (ie, how to specify a different nic, etc) because the installer should walk me through the process.

Hardware.  Compaq EVO D510 desktop.
Netinstall.  failed because the onboard nic is dead and there is no way from the installer to ignore it
dvd install.  passed sha1sum and media check.  Failed to find newt (I think)
loop mount dvd, burn boot.iso.  Expected to be asked for install method.  Was never asked, so it faiiled like the netinstall iso did

Gave up and installed Ubuntu (though I may roll back to CentOS 5 which is what was on it)

Note You need to log in before you can comment on or make changes to this bug.