Bug 476702 - (rhythmbox_downloads) Successful downloads marked as unsuccessful in Rhythmbox
Successful downloads marked as unsuccessful in Rhythmbox
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 11:27 EST by Emanuele Bellini
Modified: 2009-04-29 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 19:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rhythmbox debug: download of an episode (226.47 KB, text/plain)
2008-12-18 17:39 EST, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2008-12-16 11:27:15 EST
Description of problem:
When the download of an episode of a podcast finishes, I can see in the podcast list that the download was unsuccessful. However, if I double-click it the playback begins, that means I have the episode in my computer.


Version-Release number of selected component (if applicable):
Rhythmbox 0.11.6


Steps to Reproduce:
I have the Italian version of Rhythmbox, the menu items I wrote about could be different from the actual ones.
1. Go to "www.traxsource.com"
2. Click on the "Free podcast" link in the right column
3. Right-click on "iTunes subscribe" and select "Copy Link"
4. In Rhythmbox, select "Music/Subscribe Podcast feed..."
5. Paste the link and click "OK"
6. Right-click on the Podcast item and update the feed
7. Note that the download begins but when it finishes "Unsuccessful" is written in the progress bar.
  
Actual results:
There is written "Unsuccessful", but I have the file in my computer, also I can open it through Rhythmbox!

Expected results:
Rhythmbox should say I have the episode in my computer.
Comment 1 Bastien Nocera 2008-12-17 09:50:08 EST
Which exact version of Rhythmbox? Did you try the latest updates-testing version?
Comment 2 Emanuele Bellini 2008-12-17 17:21:51 EST
I'm going to try the test updates version, mine is 0.11.6 . This isn't a new problem for me, I had it since I switched to Linux, then in all old versions of Rhythmbox.
Comment 3 Bastien Nocera 2008-12-18 04:00:51 EST
Please don't remove the needinfo status unless you're providing all the
information requested.

If the problem still appears with the latest updates-testing version, please let me know where you try to download the Podcasts (eg. is it on a separate partition, a FAT or NTFS drive for example), and gather the output of "rhythmbox -d" when reproducing the problem.
Comment 4 Emanuele Bellini 2008-12-18 17:32:07 EST
The downloads are in the default path, that is my music folder:

/home/emanuele/Musica

I'm just uploading the output of "rhythmbox -d"...
Comment 5 Emanuele Bellini 2008-12-18 17:33:28 EST
I'm using this version of Rhythmbox now:

rpm -q rhythmbox
rhythmbox-0.11.6-17.r6096.fc10.i386

but the problem is still there!
Comment 6 Emanuele Bellini 2008-12-18 17:39:18 EST
Created attachment 327386 [details]
Rhythmbox debug: download of an episode

This is what I've done:
- I've opened Rhythmbox;
- I've seen the lists of the 3 podcasts I'm subscribed to;
- I've downloaded an episode I didn't have;
- I've selected another episode of that podcast (the reason is... it's a long story!);
- I've closed Rhythmbox.
Comment 7 Emanuele Bellini 2008-12-21 10:04:58 EST
Moreover, it isn't a new problem, I had it since I tried FC8.
The filesystem where Rhythmbox saves the files is an ext3.
Comment 8 Bastien Nocera 2009-04-28 13:12:56 EDT
I think this is due to the file having a video track. That's already been fixed upstream, will try and find the upstream report.
Comment 9 Bastien Nocera 2009-04-28 19:02:29 EDT
I knew why I remembered this bug, I filed it:
http://bugzilla.gnome.org/show_bug.cgi?id=349582
Comment 10 Emanuele Bellini 2009-04-29 16:06:59 EDT
Ok, thank you!

Note You need to log in before you can comment on or make changes to this bug.