Bug 476703 - PackageKit searches for /lib/firmware/intel-ucode/06-17-06 but doesn't offer to install any packages
PackageKit searches for /lib/firmware/intel-ucode/06-17-06 but doesn't offer ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 11:29 EST by Stewart Adam
Modified: 2009-01-14 08:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:22:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2008-12-16 11:29:02 EST
Description of problem:
It seems to be after a reboot and logging in, PackageKit will search for /lib/firmware/intel-ucode/06-17-06 but won't offer to install a new package.

Version-Release number of selected component (if applicable):
PackageKit-0.3.12-1.fc10.x86_64
udev-127-3.fc10.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1. Reboot
2. Login to user account
  
Actual results:
PackageKit keeps searching over and over for the firmware after reboots

Expected results:
PackageKit offers to install an extra package or stops searching for the firmware

Additional info:
As discussed on IRC, the problem could be because PK is searching for the wrong file (/lib/firmware/intel-ucode/06-17-06 instead of /lib/firmware/microcode.dat).


Intel hardware on this machine:
model name	: Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
Comment 1 yunus 2009-01-12 11:04:55 EST
I also encounter this ploblem sometimes on Fedora 10. I found this problem too on Fedora 9 frequently.

Here is my smolt profile
http://www.smolts.org/client/show/pub_b1a5c778-2ca6-445b-9e2a-0645c1fe0a6f
Comment 3 Richard Hughes 2009-01-14 08:20:34 EST
commit 8462a03c9c371298ef127d0525b650227d630b71
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Jan 14 13:17:55 2009 +0000

    bugfix: add intel microcode to the banned firmware list

:100644 100644 6a73ab7... ec27504... M  data/gnome-packagekit.schemas.in

commit 29e0f9f87a32fd60a9c73f4b32cb11ed5284d8df
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Jan 14 13:16:25 2009 +0000

    bugfix: allow pattern matches in the banned firmware list

Note You need to log in before you can comment on or make changes to this bug.